summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b1258220b4..551da4eafc 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -185,6 +185,39 @@ pybedtools extends BEDTools by offering feature-level manipulations from with
 Python.")
     (license license:gpl2+)))
 
+(define-public python-biopython
+  (package
+    (name "python-biopython")
+    (version "1.65")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://biopython.org/DIST/biopython-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "13m8s9jkrw40zvdp1rl709n6lmgdh4f52aann7gzr6sfp0fwhg26"))))
+    (build-system python-build-system)
+    (inputs
+     `(("python-numpy" ,python-numpy)))
+    (native-inputs
+     `(("python-setuptools" ,python2-setuptools)))
+    (home-page "http://biopython.org/")
+    (synopsis "Tools for biological computation in Python")
+    (description
+     "Biopython is a set of tools for biological computation including parsers
+for bioinformatics files into Python data structures; interfaces to common
+bioinformatics programs; a standard sequence class and tools for performing
+common operations on them; code to perform data classification; code for
+dealing with alignments; code making it easy to split up parallelizable tasks
+into separate processes; and more.")
+    (license (license:non-copyleft "http://www.biopython.org/DIST/LICENSE"))))
+
+(define-public python2-biopython
+  (package (inherit (package-with-python2 python-biopython))
+    (inputs
+     `(("python2-numpy" ,python2-numpy)))))
+
 (define-public bowtie
   (package
     (name "bowtie")