summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 66504e9efd..32f9b72d99 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -5555,10 +5555,11 @@ writing files into the .sra format.")
                (out  (assoc-ref %outputs "out"))
                (doc  (assoc-ref %outputs "doc")))
            (setenv "PATH" (string-append tar "/bin:" bzip "/bin"))
-           (system* "tar" "xvf" (assoc-ref %build-inputs "source"))
+           (invoke "tar" "xvf" (assoc-ref %build-inputs "source"))
            (chdir (string-append "seqan-library-" ,version))
            (copy-recursively "include" (string-append out "/include"))
-           (copy-recursively "share"  (string-append doc "/share"))))))
+           (copy-recursively "share"  (string-append doc "/share"))
+           #t))))
     (native-inputs
      `(("source" ,source)
        ("tar" ,tar)