summary refs log tree commit diff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm88
1 files changed, 39 insertions, 49 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 281bd1f427..0afc0a6979 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2507,16 +2508,13 @@ interrupted by stop codons.  OrfM finds and prints these ORFs.")
 (define-public python2-pbcore
   (package
     (name "python2-pbcore")
-    (version "0.9.3")
+    (version "1.2.8")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "https://github.com/PacificBiosciences/pbcore/archive/"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (uri (pypi-uri "pbcore" version))
               (sha256
                (base32
-                "1z46rwjac93jm87cbj2zgjg6qvsgs65140wkbbxsvxps7ai4pm09"))))
+                "02pfn5raa3zf739672bg0dkx7z3j2c4nx7vmpfjqy5b12jrqpymk"))))
     (build-system python-build-system)
     (arguments `(#:python ,python-2)) ; pbcore requires Python 2.7
     (inputs
@@ -2525,7 +2523,10 @@ interrupted by stop codons.  OrfM finds and prints these ORFs.")
        ("python-pysam" ,python2-pysam)
        ("python-h5py" ,python2-h5py)))
     (native-inputs
-     `(("python-setuptools" ,python2-setuptools)))
+     `(("python-docutils" ,python2-docutils)
+       ("python-nose" ,python2-nose)
+       ("python-setuptools" ,python2-setuptools)
+       ("python-sphinx" ,python2-sphinx)))
     (home-page "http://pacificbiosciences.github.io/pbcore/")
     (synopsis "Library for reading and writing PacBio data files")
     (description
@@ -3691,15 +3692,15 @@ Cuffdiff or Ballgown programs.")
 (define-public vcftools
   (package
     (name "vcftools")
-    (version "0.1.12b")
+    (version "0.1.14")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "mirror://sourceforge/vcftools/vcftools_"
-                     version ".tar.gz"))
+                    "https://github.com/vcftools/vcftools/releases/download/v"
+                    version "/vcftools-" version ".tar.gz"))
               (sha256
                (base32
-                "148al9h7f8g8my2qdnpax51kdd2yjrivlx6frvakf4lz5r8j88wx"))))
+                "10l5c07z9p4i9pr4gl54b2c9h6ndhqlbq1rashg2zcgwkbfrkmvn"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f ; no "check" target
@@ -3707,18 +3708,13 @@ Cuffdiff or Ballgown programs.")
                      "CFLAGS=-O2" ; override "-m64" flag
                      (string-append "PREFIX=" (assoc-ref %outputs "out"))
                      (string-append "MANDIR=" (assoc-ref %outputs "out")
-                                    "/share/man/man1"))
-       #:phases
-       (alist-cons-after
-        'unpack 'patch-manpage-install
-        (lambda _
-          (substitute* "Makefile"
-            (("cp \\$\\{PREFIX\\}/cpp/vcftools.1") "cp ./cpp/vcftools.1")))
-        (alist-delete 'configure %standard-phases))))
+                                    "/share/man/man1"))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (inputs
      `(("perl" ,perl)
        ("zlib" ,zlib)))
-    (home-page "http://vcftools.sourceforge.net/")
+    (home-page "https://vcftools.github.io/")
     (synopsis "Tools for working with VCF files")
     (description
      "VCFtools is a program package designed for working with VCF files, such
@@ -3726,7 +3722,7 @@ as those generated by the 1000 Genomes Project.  The aim of VCFtools is to
 provide easily accessible methods for working with complex genetic variation
 data in the form of VCF files.")
     ;; The license is declared as LGPLv3 in the README and
-    ;; at http://vcftools.sourceforge.net/license.html
+    ;; at https://vcftools.github.io/license.html
     (license license:lgpl3)))
 
 (define-public vsearch
@@ -3927,8 +3923,7 @@ barplots or heatmaps.")
                (base32
                 "0f16ryy5f012hvksrwlmm33bcl7lw97i2jvhbnwfwl03j4w7nhc1"))))
     (properties
-     `((upstream-name . "BiocGenerics")
-       (r-repository . bioconductor)))
+     `((upstream-name . "BiocGenerics")))
     (build-system r-build-system)
     (home-page "http://bioconductor.org/packages/BiocGenerics")
     (synopsis "S4 generic functions for Bioconductor")
@@ -3970,8 +3965,7 @@ abnormal copy number.")
                (base32
                 "12iibcs63m9iy7f45wgjcqsna2dnqwckphk682389grshz0g4x66"))))
     (properties
-     `((upstream-name . "S4Vectors")
-       (r-repository . bioconductor)))
+     `((upstream-name . "S4Vectors")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biocgenerics" ,r-biocgenerics)))
@@ -3998,8 +3992,7 @@ S4Vectors package itself.")
                (base32
                 "0hi5k1j5jm4xrg1l506g279qw1xkvp1gg1zgsjzpbng4vx4k4iyl"))))
     (properties
-     `((upstream-name . "IRanges")
-       (r-repository . bioconductor)))
+     `((upstream-name . "IRanges")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biocgenerics" ,r-biocgenerics)
@@ -4020,16 +4013,15 @@ possible.")
 (define-public r-genomeinfodb
   (package
     (name "r-genomeinfodb")
-    (version "1.6.1")
+    (version "1.6.3")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "GenomeInfoDb" version))
               (sha256
                (base32
-                "1j2n1v1mrw1fxn7cyffz112pm76wd6gy9q9qwlsfv3brbsqbvdbf"))))
+                "1ggp005n2rlkad00ilzn95y4rd484yr1chdhnd6fwg45rbi94d63"))))
     (properties
-     `((upstream-name . "GenomeInfoDb")
-       (r-repository . bioconductor)))
+     `((upstream-name . "GenomeInfoDb")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biocgenerics" ,r-biocgenerics)
@@ -4055,8 +4047,7 @@ names in their natural, rather than lexicographic, order.")
                (base32
                 "0havwyr6xqk7w0rmbwfj9jq1djz7wzdz7w39adhklwzwz9l4ih3a"))))
     (properties
-     `((upstream-name . "XVector")
-       (r-repository . bioconductor)))
+     `((upstream-name . "XVector")))
     (build-system r-build-system)
     (arguments
      `(#:phases
@@ -4084,16 +4075,15 @@ names in their natural, rather than lexicographic, order.")
 (define-public r-genomicranges
   (package
     (name "r-genomicranges")
-    (version "1.22.2")
+    (version "1.22.4")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "GenomicRanges" version))
               (sha256
                (base32
-                "1jffvcs0jsi7q4l3pvjj6r73vll80csgkljvhqp0g2ixc43jjng9"))))
+                "02df5683nrpn9d10ws8jz9b55nr9055hh882xp2i154xdddir0k0"))))
     (properties
-     `((upstream-name . "GenomicRanges")
-       (r-repository . bioconductor)))
+     `((upstream-name . "GenomicRanges")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biocgenerics" ,r-biocgenerics)
@@ -4215,13 +4205,13 @@ objects.")
 (define-public r-biostrings
   (package
     (name "r-biostrings")
-    (version "2.38.2")
+    (version "2.38.4")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "Biostrings" version))
               (sha256
                (base32
-                "1afp9szc8ci6jn0m3hrrqh6df65cpw3v1dcnl6xir3d3m3lwwmk4"))))
+                "0cjd7i4bdwabzb02gm753aji5xaihkj5ak8nb0d32cclxbj0hp33"))))
     (properties
      `((upstream-name . "Biostrings")))
     (build-system r-build-system)
@@ -4285,13 +4275,13 @@ files.")
 (define-public r-summarizedexperiment
   (package
     (name "r-summarizedexperiment")
-    (version "1.0.1")
+    (version "1.0.2")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "SummarizedExperiment" version))
               (sha256
                (base32
-                "0w1dwp99p6i7sc3cn0ir3dr8ksgxwjf16675h5i8n6gbv4rl9lz6"))))
+                "1gpmh1mi70m5k5qnyjs1h0qn8ajrzalzic7k3762xchxsmmdvxn4"))))
     (properties
      `((upstream-name . "SummarizedExperiment")))
     (build-system r-build-system)
@@ -4314,13 +4304,13 @@ samples.")
 (define-public r-genomicalignments
   (package
     (name "r-genomicalignments")
-    (version "1.6.1")
+    (version "1.6.3")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "GenomicAlignments" version))
               (sha256
                (base32
-                "03pxzkmwcpl0d7a09ahan0nllfv7qw2i7w361w6af2s4n3xwrniz"))))
+                "02b9j1pfd39bkvb623k5k0ziq9rpw093hifqw65vb954dwj29jhd"))))
     (properties
      `((upstream-name . "GenomicAlignments")))
     (build-system r-build-system)
@@ -4347,13 +4337,13 @@ alignments.")
 (define-public r-rtracklayer
   (package
     (name "r-rtracklayer")
-    (version "1.30.1")
+    (version "1.30.4")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "rtracklayer" version))
               (sha256
                (base32
-                "1if31hg56islx5vwydpgs5gkyas26kyvv2ljv1c7jikpm62w14qv"))))
+                "0knjnwywh9k726mq28s3sy013zhw6d6nfa8hfw670720nq18i2p0"))))
     (build-system r-build-system)
     (arguments
      `(#:phases
@@ -4392,13 +4382,13 @@ as well as query and modify the browser state, such as the current viewport.")
 (define-public r-genomicfeatures
   (package
     (name "r-genomicfeatures")
-    (version "1.22.7")
+    (version "1.22.13")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "GenomicFeatures" version))
               (sha256
                (base32
-                "1jb4s49ar5j9qslpd3kfdg2wrl4q7ciysd55h9a7zvspymxcngq8"))))
+                "0n3rkj66la6wizgcsf2rmwcsyfxz9kv5zak337lmk1raqfnancz4"))))
     (properties
      `((upstream-name . "GenomicFeatures")))
     (build-system r-build-system)
@@ -4582,13 +4572,13 @@ reference point and sorted by a user defined feature.")
 (define-public r-genomation
   (package
     (name "r-genomation")
-    (version "1.2.1")
+    (version "1.2.2")
     (source (origin
               (method url-fetch)
               (uri (bioconductor-uri "genomation" version))
               (sha256
                (base32
-                "1mzs995snwim13qk9kz4q3nczpnbsy1allwp4whfq0cflg2mndfr"))))
+                "0kvzwc21zsh2c8d34yn935ncn38bfkpzmknycd8h7b0521x20mi9"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biostrings" ,r-biostrings)