summary refs log tree commit diff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index b83bd73a39..a2253a9efc 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -44,7 +44,7 @@
 (define-public boost
   (package
     (name "boost")
-    (version "1.69.0")
+    (version "1.70.0")
     (source (origin
               (method url-fetch)
               (uri (let ((version-with-underscores
@@ -56,8 +56,7 @@
                                           version-with-underscores ".tar.bz2"))))
               (sha256
                (base32
-                "01j4n142dz20lcgqji8d8hspp04p1nv7m8i6dz8w5lchfdhx8clg"))
-              (patches (search-patches "boost-fix-icu-build.patch"))))
+                "0y47nc7w0arwgj4x1phadxbvl7wyfcgknbz5kv8lzpl98wsyh2j3"))))
     (build-system gnu-build-system)
     (inputs `(("icu4c" ,icu4c)
               ("zlib" ,zlib)))
@@ -69,7 +68,11 @@
      `(#:tests? #f
        #:make-flags
        (list "threading=multi" "link=shared"
-             "cxxflags=-std=c++14"
+
+             ;; XXX: Disable installation of Boosts modular CMake config scripts
+             ;; which conflicts in 1.70.0 with the ones provided by CMake.
+             ;; See <https://bugs.gnu.org/36721>.
+             "--no-cmake-config"
 
              ;; Set the RUNPATH to $libdir so that the libs find each other.
              (string-append "linkflags=-Wl,-rpath="