summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm35
1 files changed, 12 insertions, 23 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 60556dc501..99281b2cc6 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -813,30 +813,19 @@ to Novena upstream, does not load u-boot.img from the first partition.")
     (package
       (inherit base)
       (arguments
-       (substitute-keyword-arguments (package-arguments base)
-         ((#:phases phases)
-          `(modify-phases ,phases
-             (add-after 'unpack 'set-environment
-               (lambda* (#:key inputs #:allow-other-keys)
-                 ;; Need to copy the firmware into u-boot build
-                 ;; directory.
-                 (copy-file (string-append (assoc-ref inputs "firmware")
-                                           "/bl31.bin") "bl31-rk3399.bin")
-                 (copy-file (string-append (assoc-ref inputs "firmware-m0")
-                                           "/rk3399m0.bin") "rk3399m0.bin")
-                 #t))
-             (add-after 'build 'build-itb
-               (lambda* (#:key make-flags #:allow-other-keys)
-                 ;; The u-boot.itb is not built by default.
-                 (apply invoke "make" `(,@make-flags ,"u-boot.itb"))))
-             (add-after 'build-itb 'build-rksd
-               (lambda* (#:key inputs #:allow-other-keys)
-                 ;; Build Rockchip SD card images.
-                 (invoke "./tools/mkimage" "-T" "rksd" "-n" "rk3399" "-d"
-                         "spl/u-boot-spl.bin" "u-boot-spl.rksd")))))))
+        (substitute-keyword-arguments (package-arguments base)
+          ((#:phases phases)
+           `(modify-phases ,phases
+              (add-after 'unpack 'set-environment
+                (lambda* (#:key inputs #:allow-other-keys)
+                  (setenv "BL31" (string-append (assoc-ref inputs "firmware")
+                                                "/bl31.elf"))
+                  #t))
+              ;; Phases do not succeed on the bl31 ELF.
+              (delete 'strip)
+              (delete 'validate-runpath)))))
       (native-inputs
-       `(("firmware" ,arm-trusted-firmware-puma-rk3399)
-         ("firmware-m0" ,rk3399-cortex-m0)
+       `(("firmware" ,arm-trusted-firmware-rk3399)
          ,@(package-native-inputs base))))))
 
 (define-public u-boot-qemu-riscv64