summary refs log tree commit diff
path: root/gnu/packages/bootloaders.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bootloaders.scm')
-rw-r--r--gnu/packages/bootloaders.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 54e47059ee..7987641031 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2016, 2017, 2018, 2021 Marius Bakke <marius@gnu.org>
 ;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2016, 2017 David Craven <david@craven.ch>
-;;; Copyright © 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2019, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 nee <nee@cock.li>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -448,18 +448,21 @@ menu to select one of the installed operating systems.")
               (method url-fetch)
               (uri (string-append
                     "mirror://kernel.org/software/utils/dtc/"
-                    "dtc-" version ".tar.xz"))
+                    "dtc-" version ".tar.gz"))
               (sha256
                (base32
-                "0wrl43rvd8nnm1v1wyfdr17vk8q7ymib62vli6da8n9ni4lwbkk5"))))
+                "0xm38h31jb29xfh2sfyk48d8wdfq4b8lmb412zx9vjr35izjb9iq"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list bison
-           flex
-           libyaml
-           pkg-config
-           swig
-           valgrind))
+     (append
+       (list bison
+             flex
+             libyaml
+             pkg-config
+             swig)
+       (if (member (%current-system) (package-supported-systems valgrind))
+           (list valgrind)
+           '())))
     (inputs
      (list python))
     (arguments
@@ -480,10 +483,7 @@ menu to select one of the installed operating systems.")
              (substitute* '("Makefile"
                             "tests/run_tests.sh")
                (("pkg-config")
-                (or (which "pkg-config")
-                    (string-append ,(%current-target-system)
-                                   "-pkg-config"))))
-             #t))
+                ,(pkg-config-for-target)))))
          (delete 'configure))))         ; no configure script
     (home-page "https://www.devicetree.org")
     (synopsis "Compiles device tree source files")