summary refs log tree commit diff
path: root/gnu/packages/busybox.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/busybox.scm')
-rw-r--r--gnu/packages/busybox.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/busybox.scm b/gnu/packages/busybox.scm
index 182b8ac618..7bb677cdd0 100644
--- a/gnu/packages/busybox.scm
+++ b/gnu/packages/busybox.scm
@@ -54,6 +54,12 @@
              #t))
          (replace 'configure
            (lambda _ (invoke "make" "defconfig")))
+         (add-after 'configure 'dont-install-to-usr
+           (lambda _
+             (substitute* ".config"
+               (("# CONFIG_INSTALL_NO_USR is not set")
+                "CONFIG_INSTALL_NO_USR=y"))
+             #t))
          (replace 'check
            (lambda _
              (substitute* '("testsuite/du/du-s-works"