summary refs log tree commit diff
path: root/gnu/packages/c.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/c.scm')
-rw-r--r--gnu/packages/c.scm56
1 files changed, 44 insertions, 12 deletions
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index d82db532aa..c5141451f0 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -1,8 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016, 2018 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -160,8 +160,7 @@ standard.")
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _
-             (zero? (system* "make" "-C" "cc/cpp" "test")))))))
+           (lambda _ (invoke "make" "-C" "cc/cpp" "test") #t)))))
     (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)))
@@ -178,16 +177,53 @@ compiler while still keeping it small, simple, fast and understandable.")
 (define-public libbytesize
   (package
     (name "libbytesize")
-    (version "1.3")
+    (version "1.4")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "https://github.com/storaged-project/libbytesize/releases/download/1.3/libbytesize-"
-                    version ".tar.gz"))
+                    "https://github.com/storaged-project/libbytesize/releases/"
+                    "download/" version "/libbytesize-" version ".tar.gz"))
               (sha256
                (base32
-                "1l7mxm2vq2h6137fyfa46v9r4lydp9dvmsixkd64xr3ylqk1g6fi"))))
+                "0bbqzln1nhjxl71aydq9k4jg3hvki9lqsb4w10s1i27jgibxqkdv"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; This Makefile hard-codes MSGMERGE et al. instead of
+                  ;; honoring what 'configure' detected.  Fix that.
+                  (substitute* "po/Makefile.in"
+                    (("^MSGMERGE = msgmerge")
+                     "MSGMERGE = @MSGMERGE@\n"))
+                  #t))))
     (build-system gnu-build-system)
+    (arguments
+     ;; When running "make", the POT files are built with the build time as
+     ;; their "POT-Creation-Date".  Later on, "make" notices that .pot
+     ;; files were updated and goes on to run "msgmerge"; as a result, the
+     ;; non-deterministic POT-Creation-Date finds its way into .po files,
+     ;; and then in .gmo files.  To avoid that, simply make sure 'msgmerge'
+     ;; never runs.  See <https://bugs.debian.org/792687>.
+     '(#:configure-flags '("ac_cv_path_MSGMERGE=true")
+
+       #:phases (modify-phases %standard-phases
+                  (add-after 'configure 'create-merged-po-files
+                    (lambda _
+                      ;; Create "merged PO" (.mpo) files so that 'msgmerge'
+                      ;; doesn't need to run.
+                      (for-each (lambda (po-file)
+                                  (let ((merged-po
+                                         (string-append (dirname po-file) "/"
+                                                        (basename po-file
+                                                                  ".po")
+                                                        ".mpo")))
+                                    (copy-file po-file merged-po)))
+                                (find-files "po" "\\.po$"))
+                      #t)))
+
+       ;; One test fails because busctl (systemd only?) and python2-pocketlint
+       ;; are missing.  Should we fix it, we would need the "python-2" ,
+       ;; "python2-polib" and "python2-six" native-inputs.
+       #:tests? #f))
     (native-inputs
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)
@@ -195,10 +231,6 @@ compiler while still keeping it small, simple, fast and understandable.")
     (inputs
      `(("mpfr" ,mpfr)
        ("pcre" ,pcre)))
-    ;; One test fails because busctl (systemd only?) and python2-pocketlint
-    ;; are missing.  Should we fix it, we would need the "python-2" ,
-    ;; "python2-polib" and "python2-six" native-inputs.
-    (arguments `(#:tests? #f))
     (home-page "https://github.com/storaged-project/libbytesize")
     (synopsis "Tiny C library for working with arbitrary big sizes in bytes")
     (description