summary refs log tree commit diff
path: root/gnu/packages/calendar.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/calendar.scm')
-rw-r--r--gnu/packages/calendar.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/calendar.scm b/gnu/packages/calendar.scm
index 306c949066..70bf8f9573 100644
--- a/gnu/packages/calendar.scm
+++ b/gnu/packages/calendar.scm
@@ -88,6 +88,7 @@ data units.")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "khal" version))
+             (patches (search-patches "khal-disable-failing-tests.patch"))
              (sha256
               (base32
                "03vy4dp9n43w51mwqjjy08dr5nj7wxqnb085visz3j43vzm42p1f"))))
@@ -96,10 +97,9 @@ data units.")
      `(#:phases (modify-phases %standard-phases
         ;; Building the manpage requires khal to be installed.
         (add-after 'install 'manpage
-          (lambda* (#:key outputs #:allow-other-keys)
-            (setenv "PYTHONPATH"
-                    (string-append
-                      (getenv "PYTHONPATH") ":" (assoc-ref outputs "out")))
+          (lambda* (#:key inputs outputs #:allow-other-keys)
+            ;; Make installed package available for running the tests
+            (add-installed-pythonpath inputs outputs)
             (zero? (system* "make" "--directory=doc/" "man"))
             (install-file
               "doc/build/man/khal.1"