summary refs log tree commit diff
path: root/gnu/packages/ccache.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ccache.scm')
-rw-r--r--gnu/packages/ccache.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/ccache.scm b/gnu/packages/ccache.scm
index 112f613c88..4ff0fb2ae0 100644
--- a/gnu/packages/ccache.scm
+++ b/gnu/packages/ccache.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -31,14 +31,14 @@
 (define-public ccache
   (package
     (name "ccache")
-    (version "4.2")
+    (version "4.3")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/ccache/ccache/releases/download/v"
                            version "/ccache-" version ".tar.xz"))
        (sha256
-        (base32 "0kx9ggbbm899zwyyxvm4dgzn1b95zi1niz0l734pi5y3i0cb251g"))))
+        (base32 "1d4995lkmqshzfxlmbyn101m1rxs02yb8dgh4rl30p26hhhhyjjh"))))
     (build-system cmake-build-system)
     (native-inputs `(("perl" ,perl)     ; for test/run
                      ("which" ,(@ (gnu packages base) which))))
@@ -52,8 +52,8 @@
              (substitute* '("unittest/test_hashutil.cpp" "test/suites/base.bash")
                (("#!/bin/sh") (string-append "#!" (which "sh"))))
              #t))
-         ;; tests require a writable HOME
          (add-before 'check 'set-home
+           ;; Tests require a writable HOME.
            (lambda _
              (setenv "HOME" (getenv "TMPDIR"))
 	     #t)))))