summary refs log tree commit diff
path: root/gnu/packages/cdrom.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cdrom.scm')
-rw-r--r--gnu/packages/cdrom.scm28
1 files changed, 23 insertions, 5 deletions
diff --git a/gnu/packages/cdrom.scm b/gnu/packages/cdrom.scm
index 5d45d07288..384fc57317 100644
--- a/gnu/packages/cdrom.scm
+++ b/gnu/packages/cdrom.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
@@ -46,9 +46,10 @@
   #:use-module (gnu packages xml)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages glib)
-  #:use-module (gnu packages man)
   #:use-module (gnu packages m4)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages mp3)
+  #:use-module (gnu packages music)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages wxwidgets)
@@ -57,6 +58,7 @@
   #:use-module (gnu packages readline)
   #:use-module (gnu packages base)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages perl-web)
   #:use-module (gnu packages python)
   #:use-module (gnu packages image)
   #:use-module (gnu packages photo)
@@ -416,7 +418,7 @@ graphical interface.")
 (define-public libcue
   (package
     (name "libcue")
-    (version "2.2.0")
+    (version "2.2.1")
     (source (origin
              (method url-fetch)
              (uri (string-append
@@ -425,8 +427,10 @@ graphical interface.")
              (file-name (string-append name "-" version ".tar.gz"))
              (sha256
               (base32
-               "0y9808vbly1w6i3diaad9csjmmw6iaw572wjjr68ssqamsw193rj"))))
+               "000j5xqp7cc7njwlixr9byahz9kn8pcfdgm76afwv4p8nbmw6yzj"))))
     (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
     (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)))
@@ -513,6 +517,9 @@ from an audio CD.")
                    (parano (assoc-ref inputs "cdparanoia"))
                    (which  (assoc-ref inputs "which"))
                    (discid (assoc-ref inputs "cd-discid"))
+                   (perl-discid (assoc-ref inputs "perl-musicbrainz-discid"))
+                   (perl-ws (assoc-ref inputs "perl-webservice-musicbrainz"))
+                   (perl-mojo (assoc-ref inputs "perl-mojolicious"))
                    (flac   (assoc-ref inputs "flac"))
                    (out    (assoc-ref outputs "out")))
                (define (wrap file)
@@ -524,7 +531,14 @@ from an audio CD.")
                                                   which "/bin:"
                                                   vorbis "/bin:"
                                                   discid "/bin:"
-                                                  parano "/bin")))))
+                                                  parano "/bin")))
+                               `("PERL5LIB" ":" prefix
+                                 (,(string-append perl-discid
+                                                  "/lib/perl5/site_perl:"
+                                                  perl-ws
+                                                  "/lib/perl5/site_perl:"
+                                                  perl-mojo
+                                                  "/lib/perl5/site_perl")))))
 
                (for-each wrap
                          (find-files (string-append out "/bin")
@@ -538,6 +552,10 @@ from an audio CD.")
               ("vorbis-tools" ,vorbis-tools)
               ("flac" ,flac)
 
+              ("perl-musicbrainz-discid" ,perl-musicbrainz-discid)
+              ("perl-webservice-musicbrainz" ,perl-webservice-musicbrainz)
+              ("perl-mojolicious" ,perl-mojolicious) ;indirect dependency
+
               ;; A couple of Python and Perl scripts are included.
               ("python" ,python)
               ("perl" ,perl)))