summary refs log tree commit diff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm8
1 files changed, 1 insertions, 7 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index e671972654..17c2b7284e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -310,6 +310,7 @@ for C++ 11 and beyond implemented as a single-header library.")
               (method git-fetch)
               (uri (git-reference (url home-page) (commit version)))
               (file-name (git-file-name name version))
+              (patches (search-patches "clitest-grep-compat.patch"))
               (sha256
                (base32
                 "1p745mxiq3hgi3ywfljs5sa1psi06awwjxzw0j9c2xx1b09yqv4a"))))
@@ -325,13 +326,6 @@ for C++ 11 and beyond implemented as a single-header library.")
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
-                (substitute* "test.md"
-                  ;; One test looks for an error from grep in the form "grep: foo",
-                  ;; but our grep returns the absolute file name on errors.  Adjust
-                  ;; the test to cope with that.
-                  (("sed 's/\\^e\\*grep: \\.\\*/")
-                   "sed 's/.*e*grep: .*/"))
-
                 (setenv "HOME" "/tmp")
                 (invoke "./clitest" "test.md"))))
           (replace 'install