summary refs log tree commit diff
path: root/gnu/packages/chez.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/chez.scm')
-rw-r--r--gnu/packages/chez.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 5d152b3db5..0d22e2e20f 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -104,7 +104,7 @@ Scheme machine types, or '#f' if none is defined."
    ((target-ppc32? system)
     "ppc32")
    ((target-riscv64? system)
-    #f)
+    "rv64")
    (else
     #f)))
 
@@ -170,6 +170,7 @@ in Chez Scheme machine types, or '#f' if none is defined."
      ("a6" threads bootstrap-bootfiles)
      ("arm32" bootstrap-bootfiles)
      ("arm64" . #f)
+     ("rv64" . #f)
      ("ppc32" threads))
     ;; Hurd
     ("gnu"
@@ -466,8 +467,8 @@ and 32-bit PowerPC architectures.")
   (package
     (inherit chez-scheme)
     (name "chez-scheme-for-racket")
-    (version "9.5.9.2")
-    ;; The version should match `(scheme-fork-version-number)`.
+    (version "9.5.9.8")
+    ;; The version should match `scheme-version`.
     ;; See racket/src/ChezScheme/s/cmacros.ss c. line 360.
     ;; It will always be different than the upstream version!
     ;; When updating, remember to also update %racket-version in racket.scm.
@@ -492,12 +493,6 @@ and 32-bit PowerPC architectures.")
      (substitute-keyword-arguments (package-arguments chez-scheme)
        ((#:out-of-source? _ #f)
         #t)
-       ((#:tests? _ #t)
-        ;; FIXME: There have been some flaky test failures. Some have been
-        ;; fixed upstream post-release but have proven non-trivial to
-        ;; backport; at least one issue remains. Re-enable tests once
-        ;; https://github.com/racket/racket/issues/4359 is fixed.
-        #f)
        ((#:configure-flags cfg-flags #~'())
         #~`("--disable-x11"
             "--threads" ;; ok to potentially duplicate
@@ -590,7 +585,7 @@ supported by upstream Chez Scheme.
 Main additions to Chez Scheme in the Racket variant:
 @itemize @bullet
 @item
-AArch64 code generation
+AArch64 and RV64G (RISC-V) code generation
 @item
 Portable bytecode (@code{pb}) mode, which is mainly useful for bootstrapping a
 build on any platform, but can also be used on platforms without native-code
@@ -603,7 +598,7 @@ Faster multiplication and division for large exact numbers
 @item
 Type reconstruction during optimization (especially for safe code)
 @item
-Continuation attachments
+Continuation marks
 @item
 Parallel garbage collection, in-place garbage collection for old-generation
 objects (instead of always copying), and reachability-based memory
@@ -611,6 +606,8 @@ accounting
 @item
 Ordered finalization, immobile (but collectable) objects, weak/ephemeron
 generic hash tables, and reference bytevectors
+@item
+Easier bootstrapping via old versions of Chez Scheme
 @end itemize")
     (license asl2.0)))
 
@@ -695,7 +692,7 @@ source.")))
                       #~(invoke
                          (search-input-file (or native-inputs inputs)
                                             "/opt/racket-vm/bin/racket")
-                         "rktboot/main.rkt"
+                         "../rktboot/main.rkt"
                          #$@(if (racket-cs-native-supported-system?)
                                 #~()
                                 (let ((m (nix-system->pbarch-machine-type)))