summary refs log tree commit diff
path: root/gnu/packages/cluster.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cluster.scm')
-rw-r--r--gnu/packages/cluster.scm28
1 files changed, 13 insertions, 15 deletions
diff --git a/gnu/packages/cluster.scm b/gnu/packages/cluster.scm
index e643cc58f9..eef6527f6f 100644
--- a/gnu/packages/cluster.scm
+++ b/gnu/packages/cluster.scm
@@ -28,6 +28,7 @@
   #:use-module (guix packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages libevent)
@@ -41,26 +42,21 @@
 (define-public drbd-utils
   (package
     (name "drbd-utils")
-    (version "9.15.1")
+    (version "9.19.0")
     (source (origin
               (method url-fetch)
-              ;; Older releases are moved to /archive.  List it first because in
-              ;; practice this URL will be the most current (e.g. time-machine).
-              (uri (list (string-append "https://www.linbit.com/downloads/drbd"
-                                        "/utils/archive/drbd-utils-" version
-                                        ".tar.gz")
-                         (string-append "https://www.linbit.com/downloads/drbd"
+              (uri (list (string-append "https://pkg.linbit.com/downloads/drbd"
                                         "/utils/drbd-utils-" version ".tar.gz")))
               (sha256
                (base32
-                "1q92bwnprqkkj9iy6fxcybcfpxvvjw5clis0igrbxqnq869kwp1i"))
+                "1bbw91hil55d2047r2bdhx2daxc1wqysra2qqm77iy1hcvnvy9rq"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   (substitute* "scripts/global_common.conf"
                     ;; Do not participate in usage count survey by default.
-                    (("usage-count: yes")
-                     "usage-count: no"))
+                    (("usage-count yes")
+                     "usage-count no"))
                   (substitute* "scripts/Makefile.in"
                     ;; Install the Pacemaker resource agents to the libdir,
                     ;; regardless of what the OCF specification says...
@@ -85,6 +81,7 @@
                            "--sysconfdir=/etc"
                            "--localstatedir=/var")
        #:test-target "test"
+       #:make-flags '("WANT_DRBD_REPRODUCIBLE_BUILD=yesplease")
        #:phases
        (modify-phases %standard-phases
          (add-after 'patch-generated-file-shebangs 'patch-documentation
@@ -188,7 +185,7 @@ independently or together to provide resilient infrastructures.")
 (define-public libraft
   (package
     (name "libraft")
-    (version "0.10.1")
+    (version "0.11.2")
     (home-page "https://github.com/canonical/raft")
     (source (origin
               (method git-fetch)
@@ -197,7 +194,7 @@ independently or together to provide resilient infrastructures.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "18idj53vnl5fx1ja1zlp8kiwmdxgwjxsi88rdql0pbh0484b92a3"))))
+                "050dwy34jh8dihfwfm0r1by2i3sy9crapipp9idw32idm79y4izb"))))
     (arguments '(#:configure-flags '("--enable-uv")
                  #:phases
                  (modify-phases %standard-phases
@@ -207,7 +204,8 @@ independently or together to provide resilient infrastructures.")
                          ((".*test_uv_append.c.*") ""))
                        #t)))))
     (inputs
-     `(("libuv" ,libuv)))
+     `(("libuv" ,libuv)
+       ("lz4" ,lz4)))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
@@ -226,7 +224,7 @@ snapshots).")
 (define-public libdqlite
   (package
     (name "libdqlite")
-    (version "1.7.0")
+    (version "1.9.0")
     (home-page "https://github.com/canonical/dqlite")
     (source (origin
               (method git-fetch)
@@ -235,7 +233,7 @@ snapshots).")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "15cg8yl3n7lcg0qyg0byciz8v6y200ghmzzkwpdzggy3m6c168wl"))))
+                "0zalsvr0vy7632nhm96a29lrfy18iqsmbxpyz2lvq80mrjlbrzsn"))))
     (arguments
      '(#:phases
        (modify-phases %standard-phases