summary refs log tree commit diff
path: root/gnu/packages/commencement.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/commencement.scm')
-rw-r--r--gnu/packages/commencement.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index f6bfc27843..7c39a84008 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -2512,14 +2512,17 @@ exec " gcc "/bin/" program
               ,flags))
            ((#:phases phases '%standard-phases)
             `(modify-phases ,phases
-               (add-before 'check 'skip-fnmatch-test
-                 (lambda _
-                   ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
-                   ;; to incorrect handling of the [:alpha:] regexp character
-                   ;; class.  Ignore it.
-                   (substitute* "gnulib-tests/Makefile"
-                     (("^XFAIL_TESTS =")
-                      "XFAIL_TESTS = test-fnmatch ")))))))))))
+              ;; 'test-fnmatch' fails when using glibc-mesboot@2.16, due
+              ;; to incorrect handling of the [:alpha:] regexp character
+              ;; class.  Ignore it.
+              ,@(if (string=? (%current-system)
+                              (or "x86_64-linux" "i686-linux"))
+                  '((add-before 'check 'skip-fnmatch-test
+                      (lambda _
+                        (substitute* "gnulib-tests/Makefile"
+                          (("^XFAIL_TESTS =")
+                           "XFAIL_TESTS = test-fnmatch ")))))
+                  '()))))))))
 
 (define file
   (package