summary refs log tree commit diff
path: root/gnu/packages/conky.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/conky.scm')
-rw-r--r--gnu/packages/conky.scm31
1 files changed, 15 insertions, 16 deletions
diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 1f5b38eef4..f0f19c5a0e 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -50,22 +50,21 @@
          ;; TODO: add 'ncurses.pc' to the ncurses package.
          "-DBUILD_NCURSES=false")
        #:phases
-       (alist-cons-after
-        'unpack 'add-freetype-to-search-path
-        (lambda* (#:key inputs #:allow-other-keys)
-          (substitute* "cmake/ConkyPlatformChecks.cmake"
-            (("set\\(INCLUDE_SEARCH_PATH")
-             (string-append
-              "set(INCLUDE_SEARCH_PATH "
-              (assoc-ref inputs "freetype") "/include/freetype2 ")))
-          #t)
-        (alist-replace
-         'install
-         (lambda* (#:key outputs #:allow-other-keys)
-           (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
-             (mkdir-p bin)
-             (install-file "src/conky" bin)))
-         %standard-phases))))
+       (modify-phases %standard-phases
+         (add-after 'unpack 'add-freetype-to-search-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "cmake/ConkyPlatformChecks.cmake"
+               (("set\\(INCLUDE_SEARCH_PATH")
+                (string-append
+                 "set(INCLUDE_SEARCH_PATH "
+                 (assoc-ref inputs "freetype") "/include/freetype2 ")))
+             #t))
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((bin (string-append (assoc-ref outputs "out") "/bin")))
+               (mkdir-p bin)
+               (install-file "src/conky" bin))
+             #t)))))
     (inputs
      `(("freetype" ,freetype)
        ("ncurses" ,ncurses)