summary refs log tree commit diff
path: root/gnu/packages/cpp.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cpp.scm')
-rw-r--r--gnu/packages/cpp.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index cc5375095b..0160e42f6a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -242,16 +242,17 @@ intutive syntax and trivial integration.")
 (define-public xtl
   (package
     (name "xtl")
-    (version "0.4.8")
+    (version "0.4.14")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/QuantStack/xtl/archive/"
-                    version ".tar.gz"))
+              (method git-fetch)
+              (uri
+               (git-reference
+                (url "https://github.com/QuantStack/xtl.git")
+                (commit version)))
               (sha256
                (base32
-                "05bcz9y590b77bxcip0k31rgsapmkwqi1smvsvc84zz7m87d4jvy"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+                "0wwnd9adc1wav2299id17k5fbp0ib5gxkbihlk6jlh3v4i5nz11x"))
+              (file-name (git-file-name name version))))
     (native-inputs
      `(("googletest" ,googletest)
        ("json-modern-cxx" ,json-modern-cxx)))