summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8dfc303101..28b266114a 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9811,3 +9811,29 @@ the properties of US-specific complex data types.  This is mainly for use by
 other package developers who want to include run-time testing features in
 their own packages.")
     (license license:gpl3+)))
+
+(define-public r-assertive-data-uk
+  (package
+    (name "r-assertive-data-uk")
+    (version "0.0-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "assertive.data.uk" version))
+       (sha256
+        (base32
+         "1fzjvhwp7mwkqqix29khvs6zcrc82n6j4czvzzb473vyjyvdlj5b"))))
+    (properties
+     `((upstream-name . "assertive.data.uk")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-assertive-base" ,r-assertive-base)
+       ("r-assertive-strings" ,r-assertive-strings)))
+    (home-page "https://bitbucket.org/richierocks/assertive.data.uk")
+    (synopsis "Assertions to check properties of strings")
+    (description
+     "This package provides a set of predicates and assertions for checking
+the properties of UK-specific complex data types.  This is mainly for use by
+other package developers who want to include run-time testing features in
+their own packages.")
+    (license license:gpl3+)))