summary refs log tree commit diff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm65
1 files changed, 0 insertions, 65 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ede8a7b3ca..89c9e3a661 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26794,71 +26794,6 @@ getters and setters on fields.")
 pointers above 2G.")
     (license license:gpl3)))
 
-(define-public rust-ghash-0.5
-  (package
-    (name "rust-ghash")
-    (version "0.5.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "ghash" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0h1y3v3kj8xxkf2snv1yly0lr20fdh3jrm60p382szbiwl6pac6r"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:cargo-inputs
-       (("rust-opaque-debug" ,rust-opaque-debug-0.3)
-        ("rust-polyval" ,rust-polyval-0.6)
-        ("rust-zeroize" ,rust-zeroize-1))
-       #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.3))))
-    (home-page "https://github.com/RustCrypto/universal-hashes")
-    (synopsis "Universal hash over GF(2^128)")
-    (description "This package provides a universal hash over GF(2^128) useful
-for constructing a Message Authentication Code (MAC), as in the AES-GCM
-authenticated encryption cipher.")
-    (license (list license:expat license:asl2.0))))
-
-(define-public rust-ghash-0.3
-  (package
-    (inherit rust-ghash-0.5)
-    (name "rust-ghash")
-    (version "0.3.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "ghash" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "0xd362xh17hadc2194dd6kjjq0ak1j4x7kkmfmpq9hw2s564wc4p"))))
-    (arguments
-     `(#:cargo-inputs
-       (("rust-opaque-debug" ,rust-opaque-debug-0.3)
-        ("rust-polyval" ,rust-polyval-0.4)
-        ("rust-zeroize" ,rust-zeroize-1))
-       #:cargo-development-inputs
-       (("rust-hex-literal" ,rust-hex-literal-0.2))))))
-
-(define-public rust-ghash-0.2
-  (package
-    (inherit rust-ghash-0.3)
-    (name "rust-ghash")
-    (version "0.2.3")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "ghash" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0lijv1y6qcysnxv45ny5fjvc4v9gmpggxlj6xa4l065737nk02cz"))))
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-polyval" ,rust-polyval-0.3)
-        ("rust-zeroize" ,rust-zeroize-1))))))
-
 (define-public rust-ghost-0.1
   (package
     (name "rust-ghost")