summary refs log tree commit diff
path: root/gnu/packages/crates-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-web.scm')
-rw-r--r--gnu/packages/crates-web.scm90
1 files changed, 90 insertions, 0 deletions
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index 9e5895fc7e..ca13af85c7 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -4036,6 +4036,96 @@ applications written in Rust.  Its API is inspired by the popular
 and metrics over HTTP.")
     (license license:asl2.0)))
 
+(define-public rust-poem-1
+  (package
+    (name "rust-poem")
+    (version "1.3.59")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "poem" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0159agmjig6s45sjf1jcbira8icpbakfadwa23pc2i07gg4p8ish"))
+       (patches (search-patches "rust-poem-1-fewer-deps.patch"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t ; use of undeclared crate or module `futures_util`
+       #:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+                       ("rust-async-compression" ,rust-async-compression-0.4)
+                       ("rust-async-trait" ,rust-async-trait-0.1)
+                       ("rust-base64" ,rust-base64-0.21)
+                       ("rust-bytes" ,rust-bytes-1)
+                       ("rust-chrono" ,rust-chrono-0.4)
+                       ("rust-cookie" ,rust-cookie-0.17)
+                       ("rust-csrf" ,rust-csrf-0.4)
+                       ;("rust-eyre" ,rust-eyre-0.6)
+                       ;("rust-fluent" ,rust-fluent-0.16)
+                       ;("rust-fluent-langneg" ,rust-fluent-langneg-0.13)
+                       ;("rust-fluent-syntax" ,rust-fluent-syntax-0.11)
+                       ("rust-futures-util" ,rust-futures-util-0.3)
+                       ("rust-headers" ,rust-headers-0.3)
+                       ("rust-hex" ,rust-hex-0.4)
+                       ("rust-http" ,rust-http-0.2)
+                       ("rust-httpdate" ,rust-httpdate-1)
+                       ("rust-hyper" ,rust-hyper-0.14)
+                       ("rust-hyper-rustls" ,rust-hyper-rustls-0.24)
+                       ;("rust-intl-memoizer" ,rust-intl-memoizer-0.5)
+                       ("rust-mime" ,rust-mime-0.3)
+                       ("rust-mime-guess" ,rust-mime-guess-2)
+                       ("rust-multer" ,rust-multer-2)
+                       ("rust-nix" ,rust-nix-0.27)
+                       ("rust-openssl" ,rust-openssl-0.10)
+                       ;("rust-opentelemetry" ,rust-opentelemetry-0.21)
+                       ;("rust-opentelemetry-http" ,rust-opentelemetry-http-0.10)
+                       ;("rust-opentelemetry-prometheus" ,rust-opentelemetry-prometheus-0.14)
+                       ;("rust-opentelemetry-semantic-conventions" ,rust-opentelemetry-semantic-conventions-0.13)
+                       ("rust-parking-lot" ,rust-parking-lot-0.12)
+                       ("rust-percent-encoding" ,rust-percent-encoding-2)
+                       ("rust-pin-project-lite" ,rust-pin-project-lite-0.2)
+                       ("rust-poem-derive" ,rust-poem-derive-1)
+                       ("rust-priority-queue" ,rust-priority-queue-1)
+                       ;("rust-prometheus" ,rust-prometheus-0.13)
+                       ("rust-quick-xml" ,rust-quick-xml-0.30)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-rcgen" ,rust-rcgen-0.11)
+                       ;("rust-redis" ,rust-redis-0.23)
+                       ("rust-regex" ,rust-regex-1)
+                       ("rust-rfc7239" ,rust-rfc7239-0.1)
+                       ("rust-ring" ,rust-ring-0.16)
+                       ("rust-rust-embed" ,rust-rust-embed-8)
+                       ("rust-rustls-pemfile" ,rust-rustls-pemfile-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-serde-urlencoded" ,rust-serde-urlencoded-0.7)
+                       ("rust-serde-yaml" ,rust-serde-yaml-0.9)
+                       ("rust-smallvec" ,rust-smallvec-1)
+                       ;("rust-sse-codec" ,rust-sse-codec-0.3)
+                       ("rust-tempfile" ,rust-tempfile-3)
+                       ("rust-thiserror" ,rust-thiserror-1)
+                       ("rust-time" ,rust-time-0.3)
+                       ("rust-tokio" ,rust-tokio-1)
+                       ("rust-tokio-metrics" ,rust-tokio-metrics-0.3)
+                       ("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
+                       ("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
+                       ("rust-tokio-rustls" ,rust-tokio-rustls-0.24)
+                       ("rust-tokio-stream" ,rust-tokio-stream-0.1)
+                       ("rust-tokio-tungstenite" ,rust-tokio-tungstenite-0.20)
+                       ("rust-tokio-util" ,rust-tokio-util-0.7)
+                       ("rust-tower" ,rust-tower-0.4)
+                       ("rust-tracing" ,rust-tracing-0.1)
+                       ;("rust-unic-langid" ,rust-unic-langid-0.9)
+                       ("rust-wildmatch" ,rust-wildmatch-2)
+                       ("rust-x509-parser" ,rust-x509-parser-0.15))
+       #:cargo-development-inputs (("rust-async-stream" ,rust-async-stream-0.3)
+                                   ("rust-tokio" ,rust-tokio-1))))
+    (home-page "https://github.com/poem-web/poem")
+    (synopsis
+     "Web framework written in the Rust programming language")
+    (description "Poem is a full-featured and easy-to-use web framework written
+in the Rust programming language.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-poem-derive-1
   (package
     (name "rust-poem-derive")