summary refs log tree commit diff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm67
1 files changed, 34 insertions, 33 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index b6f2010a80..1a26d7ab37 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -86,6 +86,7 @@
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
@@ -878,7 +879,7 @@ SHA-1, SHA-2, and SHA-3, yet is at least as secure as SHA-3.")
 (define-public rhash
   (package
     (name "rhash")
-    (version "1.3.9")
+    (version "1.4.2")
     (source
      (origin
        (method url-fetch)
@@ -887,40 +888,40 @@ SHA-1, SHA-2, and SHA-3, yet is at least as secure as SHA-3.")
        (file-name (string-append "rhash-" version ".tar.gz"))
        (sha256
         (base32
-         "1xn9fqa6rlnhsbgami45g82dlw9i1skg2sri3ydiinwak5ph1ca2"))))
+         "0qpc1fq7gdxxl11zya1gqhl9628jjk3x60q9sna43w0yz7sh03b0"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags
-       (list (string-append "--prefix=" (assoc-ref %outputs "out"))
-             ,@(let ((target (%current-target-system)))
-                 (if target
-                     `((string-append "--target=" ,target)
-                       (string-append "--cc="
-                                      (assoc-ref %build-inputs "cross-gcc")
-                                      "/bin/" ,target "-gcc"))
-                     '())))
-       #:make-flags
-       ;; The binaries in /bin need some help finding librhash.so.0.
-       (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
-       #:test-target "test"             ; ‘make check’ just checks the sources
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'configure
-           ;; ./configure is not GNU autotools' and doesn't gracefully handle
-           ;; unrecognized options, so we must call it manually.
-           (lambda* (#:key configure-flags #:allow-other-keys)
-             (apply invoke "./configure" configure-flags)))
-         (add-before 'check 'patch-/bin/sh
-           (lambda _
-             (substitute* "Makefile"
-               (("/bin/sh") (which "sh")))
-             #t))
-         (add-after 'install 'install-library-extras
-           (lambda* (#:key make-flags #:allow-other-keys)
-             (apply invoke
-                    "make" "-C" "librhash"
-                    "install-lib-headers" "install-so-link"
-                    make-flags))))))
+     (list #:configure-flags
+           #~(list (string-append "--prefix=" #$output)
+                   #$@(let ((target (%current-target-system)))
+                        (if target
+                            #~((string-append "--target=" #$target)
+                               (string-append "--cc="
+                                              (assoc-ref %build-inputs "cross-gcc")
+                                              "/bin/" #$target "-gcc"))
+                            #~())))
+           #:make-flags
+           ;; The binaries in /bin need some help finding librhash.so.0.
+           #~(list (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
+           #:test-target "test"         ; ‘make check’ just checks the sources
+           #:phases
+           #~(modify-phases %standard-phases
+              (delete 'configure)
+              (add-before 'build 'configure
+                ;; ./configure is not GNU autotools' and doesn't gracefully handle
+                ;; unrecognized options, so we must call it manually.
+                (lambda* (#:key configure-flags #:allow-other-keys)
+                  (apply invoke "./configure" configure-flags)))
+              (add-before 'check 'patch-/bin/sh
+                (lambda _
+                  (substitute* "Makefile"
+                    (("/bin/sh") (which "sh")))))
+              (add-after 'install 'install-library-extras
+                (lambda* (#:key make-flags #:allow-other-keys)
+                  (apply invoke
+                         "make" "-C" "librhash"
+                         "install-lib-headers" "install-so-link"
+                         make-flags))))))
     (home-page "https://sourceforge.net/projects/rhash/")
     (synopsis "Utility for computing hash sums")
     (description "RHash is a console utility for calculation and verification