summary refs log tree commit diff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 730895efd9..ae6150b0ab 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -523,7 +523,7 @@ attacks than alternative functions such as @code{PBKDF2} or @code{bcrypt}.")
     (native-inputs
      `(("perl-module-build" ,perl-module-build)
        ("perl-test-nowarnings" ,perl-test-nowarnings)))
-    (home-page "http://search.cpan.org/dist/Math-Random-ISAAC-XS")
+    (home-page "https://metacpan.org/release/Math-Random-ISAAC-XS")
     (synopsis "C implementation of the ISAAC PRNG algorithm")
     (description "ISAAC (Indirection, Shift, Accumulate, Add, and Count) is a
 fast pseudo-random number generator.  It is suitable for applications where a
@@ -551,7 +551,7 @@ This package implements the same interface as @code{Math::Random::ISAAC}.")
      `(("perl-test-nowarnings" ,perl-test-nowarnings)))
     (propagated-inputs
      `(("perl-math-random-isaac-xs" ,perl-math-random-isaac-xs)))
-    (home-page "http://search.cpan.org/dist/Math-Random-ISAAC")
+    (home-page "https://metacpan.org/release/Math-Random-ISAAC")
     (synopsis "Perl interface to the ISAAC PRNG algorithm")
     (description "ISAAC (Indirection, Shift, Accumulate, Add, and Count) is a
 fast pseudo-random number generator.  It is suitable for applications where a
@@ -587,7 +587,7 @@ generator.")
        ("perl-namespace-clean" ,perl-namespace-clean)
        ("perl-sub-exporter" ,perl-sub-exporter)
        ("perl-type-tiny" ,perl-type-tiny)))
-    (home-page "http://search.cpan.org/dist/Crypt-Random-Source")
+    (home-page "https://metacpan.org/release/Crypt-Random-Source")
     (synopsis "Get weak or strong random data from pluggable sources")
     (description "This module provides implementations for a number of
 byte-oriented sources of random data.")
@@ -616,7 +616,7 @@ byte-oriented sources of random data.")
        ("perl-math-random-isaac" ,perl-math-random-isaac)
        ("perl-math-random-isaac-xs" ,perl-math-random-isaac-xs)
        ("perl-moo" ,perl-moo)))
-    (home-page "http://search.cpan.org/dist/Math-Random-Secure")
+    (home-page "https://metacpan.org/release/Math-Random-Secure")
     (synopsis "Cryptographically secure replacement for rand()")
     (description "This module is intended to provide a
 cryptographically-secure replacement for Perl's built-in @code{rand} function.
@@ -794,14 +794,14 @@ using ctypes is included, and several other language bindings are available.")
 (define-public ccrypt
   (package
     (name "ccrypt")
-    (version "1.10")
+    (version "1.11")
     (source (origin
               (method url-fetch)
-              (uri (string-append "mirror://sourceforge/ccrypt/ccrypt/"
+              (uri (string-append "mirror://sourceforge/ccrypt/"
                                   version "/ccrypt-" version ".tar.gz"))
               (sha256
                (base32
-                "184v9676hx2w875cz04rd3a20wrcms33a1zwybvapb0g2yi6vml7"))))
+                "0kx4a5mhmp73ljknl2lcccmw9z3f5y8lqw0ghaymzvln1984g75i"))))
     (build-system gnu-build-system)
     (home-page "http://ccrypt.sourceforge.net")
     (synopsis "Command-line utility for encrypting and decrypting files and streams")