summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm40
1 files changed, 26 insertions, 14 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 74483d27f7..cc0f0d28e9 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1556,20 +1556,32 @@ organized in a hash table or B+ tree.")
     (build-system gnu-build-system)
     (arguments
      (list #:configure-flags
-           '(list "--disable-static"
-                  (string-append "--with-bash-headers="
-                                 (dirname (search-input-directory
-                                           %build-inputs
-                                           "include/bash"))))))
+           #~(list "--disable-static"
+                   (string-append "--with-bash-headers="
+                                  (search-input-directory %build-inputs
+                                                          "include/bash")))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'install 'symlink-bash-loadables
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (with-directory-excursion (string-append
+                                              (assoc-ref outputs "out")
+                                              "/lib")
+                     (mkdir "bash")
+                     (for-each
+                      (compose symlink
+                               (lambda (loadable)
+                                 (values
+                                  (string-append (getcwd) "/" loadable ".so")
+                                  (string-append "bash/" loadable))))
+                      '("readrec" "testrec"))))))))
     (native-inputs
-     ;; XXX Without labels, the default 'configure phase picks the wrong "bash".
-     `(("bc" ,bc)
-       ("bash:include" ,bash "include")
-       ("check" ,check)
-       ("pkg-config" ,pkg-config)))
+     (list bc check-0.14 pkg-config))
     (inputs
      ;; TODO: Add more optional inputs.
-     (list curl
+     (list bash                         ; /bin/bash for native compilation
+           `(,bash "include")
+           curl
            libgcrypt
            `(,util-linux "lib")))
     (synopsis "Manipulate plain text files as databases")
@@ -4289,7 +4301,7 @@ the SQL language using a syntax that reflects the resulting query.")
 (define-public apache-arrow
   (package
     (name "apache-arrow")
-    (version "12.0.0")
+    (version "12.0.1")
     (source
      (origin
        (method git-fetch)
@@ -4299,7 +4311,7 @@ the SQL language using a syntax that reflects the resulting query.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "057n3l9bpnfn8fqlqblkdz4w4rkmkr7zrh3adlgfw4nipwmm38zj"))))
+         "03flvb4xj6a7mfphx68ndrqr6g5jphmzb75m16fx7rnbzira2zpz"))))
     (build-system cmake-build-system)
     (arguments
      (list
@@ -5075,7 +5087,7 @@ compatible with SQLite using a graphical user interface.")
                   go-github-com-pkg-errors
                   go-github-com-sourcegraph-jsonrpc2
                   go-golang-org-x-crypto
-                  go-github.com-mattn-go-runewidth
+                  go-github-com-mattn-go-runewidth
                   go-golang-org-x-xerrors
                   go-gopkg-in-yaml-v2))
     (synopsis "SQL language server written in Go")