summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 3ab2fcdcf3..5185e3ee7f 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -133,7 +133,19 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
          "-DINSTALL_SHAREDIR=share/mysql"
          ;; Get rid of test data.
          "-DINSTALL_MYSQLTESTDIR="
-         "-DINSTALL_SQLBENCHDIR=")))
+         "-DINSTALL_SQLBENCHDIR=")
+       #:phases (modify-phases %standard-phases
+                  (add-after
+                   'install 'strip-extra-references
+                   (lambda* (#:key outputs #:allow-other-keys)
+                     ;; Strip references to GCC and other build-time
+                     ;; dependencies.
+                     (let ((out (assoc-ref outputs "out")))
+                       (for-each remove-store-references
+                                 (list (string-append out "/bin/mysqlbug")
+                                       (string-append
+                                        out "/share/mysql/docs/INFO_BIN")))
+                       #t))))))
     (native-inputs
      `(("bison" ,bison)
        ("perl" ,perl)))