summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm104
1 files changed, 51 insertions, 53 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 0fa5bfbf54..eb38e15f76 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2012, 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2013, 2017 Cyril Roelandt <tipecaml@gmail.com>
 ;;; Copyright © 2014, 2016 David Thompson <davet@gnu.org>
@@ -163,14 +163,14 @@ either single machines or networked clusters.")
 (define-public gdbm
   (package
     (name "gdbm")
-    (version "1.13")
+    (version "1.14.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/gdbm/gdbm-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "0lx201q20dvc70f8a3c9s7s18z15inlxvbffph97ngvrgnyjq9cx"))))
+                "0pxwz3jlwvglq2mrbxvrjgr8pa0aj73p3v9sxmdlj570zw0gzknd"))))
     (arguments `(#:configure-flags '("--enable-libgdbm-compat")))
     (build-system gnu-build-system)
     (home-page "http://www.gnu.org.ua/software/gdbm")
@@ -254,23 +254,22 @@ standard Go idioms.")
                  (("docdir[[:blank:]]*=.*")
                   (string-append "docdir = " doc "/share/doc/bdb")))
 
-               (zero?
-                (system* "./dist/configure"
-                         (string-append "--prefix=" out)
-                         (string-append "CONFIG_SHELL=" (which "bash"))
-                         (string-append "SHELL=" (which "bash"))
+               (invoke "./dist/configure"
+                       (string-append "--prefix=" out)
+                       (string-append "CONFIG_SHELL=" (which "bash"))
+                       (string-append "SHELL=" (which "bash"))
 
-                         ;; Remove 7 MiB of .a files.
-                         "--disable-static"
+                       ;; Remove 7 MiB of .a files.
+                       "--disable-static"
 
-                         ;; The compatibility mode is needed by some packages,
-                         ;; notably iproute2.
-                         "--enable-compat185"
+                       ;; The compatibility mode is needed by some packages,
+                       ;; notably iproute2.
+                       "--enable-compat185"
 
-                         ;; The following flag is needed so that the inclusion
-                         ;; of db_cxx.h into C++ files works; it leads to
-                         ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
-                         "--enable-cxx"))))))))
+                       ;; The following flag is needed so that the inclusion
+                       ;; of db_cxx.h into C++ files works; it leads to
+                       ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
+                       "--enable-cxx")))))))
     (synopsis "Berkeley database")
     (description
      "Berkeley DB is an embeddable database allowing developers the choice of
@@ -308,28 +307,27 @@ SQL, Key/Value, XML/XQuery or Java Object storage for their data model.")
                  (("docdir[[:blank:]]*=.*")
                   (string-append "docdir = " doc "/share/doc/bdb")))
 
-               (zero?
-                (system* "./dist/configure"
-                         (string-append "--prefix=" out)
-                         (string-append "CONFIG_SHELL=" (which "bash"))
-                         (string-append "SHELL=" (which "bash"))
+               (invoke "./dist/configure"
+                       (string-append "--prefix=" out)
+                       (string-append "CONFIG_SHELL=" (which "bash"))
+                       (string-append "SHELL=" (which "bash"))
 
-                         ;; Bdb doesn't recognize aarch64 as an architecture.
-                         ,@(if (string=? "aarch64-linux" (%current-system))
-                               '("--build=aarch64-unknown-linux-gnu")
-                               '())
+                       ;; Bdb doesn't recognize aarch64 as an architecture.
+                       ,@(if (string=? "aarch64-linux" (%current-system))
+                             '("--build=aarch64-unknown-linux-gnu")
+                             '())
 
-                         ;; Remove 7 MiB of .a files.
-                         "--disable-static"
+                       ;; Remove 7 MiB of .a files.
+                       "--disable-static"
 
-                         ;; The compatibility mode is needed by some packages,
-                         ;; notably iproute2.
-                         "--enable-compat185"
+                       ;; The compatibility mode is needed by some packages,
+                       ;; notably iproute2.
+                       "--enable-compat185"
 
-                         ;; The following flag is needed so that the inclusion
-                         ;; of db_cxx.h into C++ files works; it leads to
-                         ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
-                         "--enable-cxx"))))))))))
+                       ;; The following flag is needed so that the inclusion
+                       ;; of db_cxx.h into C++ files works; it leads to
+                       ;; HAVE_CXX_STDHEADERS being defined in db_cxx.h.
+                       "--enable-cxx")))))))))
 
 (define-public es-dump-restore
   (package
@@ -439,7 +437,8 @@ applications.")
                                 (string-append "src/third_party/" dir)))
                             '("pcre-8.41" "scons-2.5.0" "snappy-1.1.3"
                               "valgrind-3.11.0" "wiredtiger"
-                              "yaml-cpp-0.5.3" "zlib-1.2.8"))))
+                              "yaml-cpp-0.5.3" "zlib-1.2.8"))
+                  #t))
               (patches
                (list
                 (search-patch "mongodb-support-unknown-linux-distributions.patch")))))
@@ -596,7 +595,8 @@ RDBMS systems (which are deep in functionality).")
                      (substitute* "cmake/boost.cmake"
                        (("59")
                         ,(match (string-split (package-version boost) #\.)
-                           ((_ minor . _) minor))))))
+                           ((_ minor . _) minor))))
+                     #t))
                   (add-after
                    'install 'remove-extra-binaries
                    (lambda* (#:key outputs #:allow-other-keys)
@@ -682,7 +682,8 @@ Language.")
               (with-directory-excursion out
                 (for-each delete-file-recursively
                           '("data" "mysql-test" "sql-bench"
-                            "share/man/man1/mysql-test-run.pl.1")))))))))
+                            "share/man/man1/mysql-test-run.pl.1")))
+              #t))))))
     (native-inputs
      `(("bison" ,bison)
        ("perl" ,perl)))
@@ -726,10 +727,10 @@ as a drop-in replacement of MySQL.")
                        #t))
          (add-after 'build 'build-contrib
            (lambda _
-             (zero? (system* "make" "-C" "contrib"))))
+             (invoke "make" "-C" "contrib")))
          (add-after 'install 'install-contrib
            (lambda _
-             (zero? (system* "make" "-C" "contrib" "install")))))))
+             (invoke "make" "-C" "contrib" "install"))))))
     (inputs
      `(("readline" ,readline)
        ("libuuid" ,util-linux)
@@ -1007,7 +1008,7 @@ for example from a shell script.")
 (define-public sqlite
   (package
    (name "sqlite")
-   (version "3.21.0")
+   (version "3.23.0")
    (source (origin
             (method url-fetch)
             (uri (let ((numeric-version
@@ -1019,11 +1020,11 @@ for example from a shell script.")
                                             (map (cut string-pad <> 2 #\0)
                                                  other-digits))
                                            6 #\0))))))
-                   (string-append "https://sqlite.org/2017/sqlite-autoconf-"
+                   (string-append "https://sqlite.org/2018/sqlite-autoconf-"
                                   numeric-version ".tar.gz")))
             (sha256
              (base32
-              "1qxvzdjwzw6k0kqjfabj86rnq87xdbwbca7laxxdhnh0fmkm3pfp"))))
+              "0jbf78g3cm5wq77k7sfg8fb6rz44hnp9hs7p5d66fwd000c1lwdp"))))
    (build-system gnu-build-system)
    (inputs `(("readline" ,readline)))
    (arguments
@@ -1628,12 +1629,7 @@ trees (LSM), for sustained throughput under random insert workloads.")
        #:configure-flags
        (list (string-append "--with-libwiredtiger-prefix="
                             (assoc-ref %build-inputs "wiredtiger")))
-       #:make-flags '("GUILE_AUTO_COMPILE=0")
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'bootstrap
-           (lambda _
-             (invoke "sh" "bootstrap"))))))
+       #:make-flags '("GUILE_AUTO_COMPILE=0")))
     ;; TODO: Remove microkanren.scm when we have a separate package
     ;; for it.
     (native-inputs
@@ -1941,10 +1937,12 @@ etc., and an SQL engine for performing simple SQL queries.")
               (modules '((guix build utils)))
               (snippet
                ;; Delete bundled lmdb source files.
-               '(for-each delete-file (list "lib/lmdb.h"
-                                            "lib/mdb.c"
-                                            "lib/midl.c"
-                                            "lib/midl.h")))))
+               '(begin
+                  (for-each delete-file (list "lib/lmdb.h"
+                                              "lib/mdb.c"
+                                              "lib/midl.c"
+                                              "lib/midl.h"))
+                  #t))))
     (build-system python-build-system)
     (inputs
      `(("lmdb" ,lmdb)))