summary refs log tree commit diff
path: root/gnu/packages/debug.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/debug.scm')
-rw-r--r--gnu/packages/debug.scm23
1 files changed, 22 insertions, 1 deletions
diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 94312e7c05..80685900eb 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -199,6 +199,11 @@ tools that process C/C++ code.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'fix-linkage
+           (lambda _
+            (substitute* "clang_delta/CMakeLists.txt"
+              (("\\$\\{LLVM_LINK_LLVM_DYLIB\\}") "True")
+              (("  LLVM") "  LLVMSupport"))))
          (add-before 'build 'hardcode-paths
            (lambda _
             (substitute* "cvise.py"
@@ -755,9 +760,25 @@ use than similar tools like @command{mtrace}.")
         (base32 "1w8ib2vg3pg68d9hh97fw5042c73i9nqavdddc87n9bpscjbaf0d"))))
     (build-system gnu-build-system)
     (inputs
-     (list ncurses readline))
+     (list bash-minimal ncurses readline gdb))
     (native-inputs
      (list flex texinfo))
+    (arguments
+     `(#:configure-flags
+        (list
+          (string-append "ac_cv_rl_version=" ,(package-version readline))
+          "ac_cv_file__dev_ptmx=no"
+          "ac_cv_file__proc_self_status=no"
+          "ac_cv_func_setpgrp_void=no")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((gdb (search-input-file inputs "bin/gdb"))
+                   (sh (search-input-file inputs "bin/sh")))
+               (substitute* "lib/util/fork_util.cpp"
+                 (("GDB = \"gdb\"") (string-append "GDB = \"" gdb "\"")))
+               (substitute* "cgdb/cgdb.cpp" (("/bin/sh") sh))))))))
     (home-page "https://cgdb.github.io")
     (synopsis "Console front-end to the GNU debugger")
     (description