summary refs log tree commit diff
path: root/gnu/packages/dictionaries.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/dictionaries.scm')
-rw-r--r--gnu/packages/dictionaries.scm42
1 files changed, 15 insertions, 27 deletions
diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 5ca9e128ff..f9d6e57877 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016, 2021 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016, 2017, 2018, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2017, 2018, 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
@@ -100,9 +100,7 @@
                              "vera.texi" "--force" "--html" "-o"
                              (string-append html "/vera.html"))))
       #:modules ((guix build utils))))
-    (native-inputs `(("texinfo" ,texinfo)
-                     ("tar" ,tar)
-                     ("gzip" ,gzip)))
+    (native-inputs (list texinfo tar gzip))
     (home-page "https://savannah.gnu.org/projects/vera/")
     (synopsis "List of acronyms")
     (description
@@ -167,7 +165,7 @@ work, such as sentence length and other readability measures.")
                (base32
                 "0chjqs3z9zs1w3l7b5lsaj682rgnkf9kibcbzhggqqcn1pbvl5sq"))))
     (build-system gnu-build-system)
-    (inputs `(("tk" ,tk)))
+    (inputs (list tk))
     (arguments
      `(#:phases
        (modify-phases %standard-phases
@@ -178,8 +176,7 @@ work, such as sentence length and other readability measures.")
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((bindir (string-append
                             (assoc-ref %outputs "out") "/bin"))
-                   (wish (string-append (assoc-ref inputs "tk")
-                          "/bin/wish8.6"))
+                   (wish (search-input-file inputs "/bin/wish8.6"))
                    (sharedir (string-append
                               (assoc-ref %outputs "out")
                               "/share/applications"))
@@ -291,9 +288,7 @@ and a Python library.")
                   (guix build utils))
        #:test-target "test"))
     (inputs
-     `(("curl" ,curl)
-       ("fribidi" ,fribidi)
-       ("rlwrap" ,rlwrap)))
+     (list curl fribidi rlwrap))
     (native-inputs
      `(("emacs" ,emacs-minimal)
        ("util-linux" ,util-linux)))     ; hexdump, for the test
@@ -309,18 +304,20 @@ translation engines from your terminal.")
 (define-public lttoolbox
   (package
     (name "lttoolbox")
-    (version "3.5.3")
+    (version "3.5.4")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "https://github.com/apertium/lttoolbox/releases/download/v"
-             version "/lttoolbox-" version ".tar.bz2"))
+             version "/lttoolbox-" version ".tar.xz"))
        (sha256
-        (base32 "109l91ailish1a3vya5zmfg3kb67cwyzl36ndnh8f59chsbm6n2f"))))
+        (base32 "0kn9xg9sc64amd6ah5gi4qij0bhfbmc2jjvxbjjrsdd8iq054cgm"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags
+       (list "--disable-static")
+       #:phases
        (modify-phases %standard-phases
          (replace 'bootstrap
            ;; The included ./autogen.sh unconditionally runs ./configure before
@@ -328,12 +325,9 @@ translation engines from your terminal.")
            (lambda _
              (invoke "autoreconf" "-vfi"))))))
     (inputs
-     `(("libxml2" ,libxml2)))
+     (list libxml2))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("pkg-config" ,pkg-config)))
+     (list autoconf automake libtool pkg-config))
     (home-page "https://wiki.apertium.org/wiki/Lttoolbox")
     (synopsis "Lexical processing toolbox")
     (description "Lttoolbox is a toolbox for lexical processing, morphological
@@ -359,10 +353,7 @@ word (e.g. cats) into its lemma \"cat\" and the grammatical information
        (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
     (inputs
-     `(("libxml2" ,libxml2)
-       ("libxslt" ,libxslt)
-       ("lttoolbox" ,lttoolbox)
-       ("pcre" ,pcre)))
+     (list libxml2 libxslt lttoolbox pcre))
     (native-inputs
      `(("apertium-get"
         ,(origin
@@ -434,10 +425,7 @@ intelligible and easily correctable.")
      `(("gettext" ,gettext-minimal)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("glib" ,glib)
-       ("ncurses" ,ncurses)
-       ("readline" ,readline)
-       ("zlib" ,zlib)))
+     (list glib ncurses readline zlib))
     (home-page "https://dushistov.github.io/sdcv/")
     (synopsis "Console version of StarDict")
     (description "sdcv is simple text-based utility for work with dictionaries