summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm42
1 files changed, 14 insertions, 28 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 3e7ab7d7ba..cb835f1c58 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -72,7 +72,7 @@
 (define-public diffoscope
   (package
     (name "diffoscope")
-    (version "151")
+    (version "161")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -81,40 +81,16 @@
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1lv44ngqij9dp3xk9jj95w7an7h03iac6b2ifpq33j5fffswa1sm"))))
+                "1c9afc0s8p2wh7pw7xclr8j06ma3fjk6r1dnfaf1gdfk05hdxi78"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
-                  ;; setup.py mistakenly requires python-magic from PyPi, even
-                  ;; though the Python bindings of `file` are sufficient.
-                  ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
-                  (add-after 'unpack 'dependency-on-python-magic
-                    (lambda _
-                      (substitute* "setup.py"
-                        (("'python-magic',") ""))))
                   ;; This test is broken because our `file` package has a
                   ;; bug in berkeley-db file type detection.
                   (add-after 'unpack 'remove-berkeley-test
                     (lambda _
                       (delete-file "tests/comparators/test_berkeley_db.py")
                       #t))
-                  ;; Test is dynamically generated and may have false
-                  ;; negatives with different ocaml versions.  Further
-                  ;; background in: https://bugs.debian.org/939386
-                  (add-after 'unpack 'remove-ocaml-test
-                    (lambda _
-                      (substitute* "tests/comparators/test_ocaml.py"
-                        (("def test_diff.differences.:")
-                         "def skip_test_diff(differences):"))
-                      #t))
-                  (add-after 'unpack 'skip-elf-tests
-                    ;; FIXME: libmix_differences test added in 125, and is
-                    ;; failing, need to explore why...
-                    (lambda _
-                      (substitute* "tests/comparators/test_elf.py"
-                        (("def test_libmix_differences.libmix_differences.:")
-                         "def skip_test_libmix_differences(libmix_differences):"))
-                      #t))
                   (add-after 'unpack 'embed-tool-references
                     (lambda* (#:key inputs #:allow-other-keys)
                       (substitute* "diffoscope/comparators/utils/compare.py"
@@ -145,6 +121,13 @@
                       ;; This requires /sbin to be in $PATH.
                       (delete-file "tests/test_tools.py")
                       #t))
+                  (add-before 'check 'skip-dex-test-with-missing-procyon
+                    (lambda _
+                      ;; This test actually requires procyon decompiler
+                      (substitute* "tests/comparators/test_dex.py"
+                        (("skip_unless_tools_exist.\"enjarify\", \"zipinfo\", \"javap\"")
+                         "skip_unless_tools_exist(\"enjarify\", \"zipinfo\", \"javap\", \"procyon\""))
+                     #t))
                   (add-after 'install 'install-man-page
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((out (assoc-ref outputs "out"))
@@ -155,6 +138,7 @@
               ("python-file" ,python-file)
               ("python-debian" ,python-debian)
               ("python-libarchive-c" ,python-libarchive-c)
+              ("python-magic" ,python-magic)
               ("python-tlsh" ,python-tlsh)
               ("acl" ,acl)              ;for getfacl
               ("colordiff" ,colordiff)
@@ -164,6 +148,7 @@
                      ("python-pytest" ,python-pytest)
                      ("python-chardet" ,python-chardet)
                      ("python-binwalk" ,python-binwalk)
+                     ("python-black" ,python-black)
                      ("python-h5py" ,python-h5py)
                      ("python-pypdf2" ,python-pypdf2)
                      ("python-progressbar33" ,python-progressbar33)
@@ -240,7 +225,7 @@ install.")
 (define-public reprotest
   (package
     (name "reprotest")
-    (version "0.7.14")
+    (version "0.7.15")
     (source
      (origin
        (method git-fetch)
@@ -250,7 +235,7 @@ install.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "12d07xq5zx5dfbsgakm6zcn7hgf0h9f5kvfjqkiyak4ix5aa6xkf"))))
+         "12lc1pb9d5h3blrzzx9nbqqj5bi9x23yj31fxafmk37803rl8a0m"))))
     (inputs
      `(("python-debian" ,python-debian)
        ("python-distro" ,python-distro)
@@ -262,6 +247,7 @@ install.")
        ("libfaketime" ,libfaketime)
        ("python-coverage" ,python-coverage)
        ("python-docutils" ,python-docutils)
+       ("python-magic " ,python-magic)
        ("python-pytest " ,python-pytest)
        ("python-tlsh" ,python-tlsh)
        ("python-tox" ,python-tox)