summary refs log tree commit diff
path: root/gnu/packages/digest.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/digest.scm')
-rw-r--r--gnu/packages/digest.scm36
1 files changed, 22 insertions, 14 deletions
diff --git a/gnu/packages/digest.scm b/gnu/packages/digest.scm
index 0af6720c03..4211848fdb 100644
--- a/gnu/packages/digest.scm
+++ b/gnu/packages/digest.scm
@@ -19,6 +19,7 @@
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages digest)
+  #:use-module (guix gexp)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -66,7 +67,8 @@ Zig, V, and Nim programming language standard libraries.")
 (define-public xxhash
   (package
     (name "xxhash")
-    (version "0.8.0")
+    ;; XXX Remove the 'fix-man-page-links phase when updating.
+    (version "0.8.1")
     (source
      (origin
        (method git-fetch)
@@ -75,21 +77,27 @@ Zig, V, and Nim programming language standard libraries.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0hpbzdd6kfki5f61g103vp7pfczqkdj0js63avl0ss552jfb8h96"))))
+        (base32 "1h6080lvcr5mpbvy4fhb4i7wvhpy72nrixk3djmpai4hxq41hsnr"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags
-       (list ,(string-append "CC=" (cc-for-target))
-             ,(match (or (%current-target-system)
-                         (%current-system))
-                ;; Detect vector instruction set at run time.
-                ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
-                (_ "DISPATCH=0"))
-             "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
-             (string-append "prefix=" (assoc-ref %outputs "out")))
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))         ; no configure script
+     (list #:make-flags
+           #~(list #$(string-append "CC=" (cc-for-target))
+                   #$(match (or (%current-target-system)
+                                (%current-system))
+                       ;; Detect vector instruction set at run time.
+                       ((or "i686-linux" "x86_64-linux") "DISPATCH=1")
+                       (_ "DISPATCH=0"))
+                   "XXH_FORCE_MEMORY_ACCESS=1" ; improved performance with GCC
+                   (string-append "prefix=" (assoc-ref %outputs "out")))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'fix-man-page-links
+                 ;; https://github.com/Cyan4973/xxHash/issues/647
+                 (lambda _
+                   (substitute* "Makefile"
+                     (("ln -sf \\$\\(MAN\\)")
+                      "ln -sf xxhsum.1"))))
+               (delete 'configure))))         ; no configure script
     (home-page "https://cyan4973.github.io/xxHash/")
     (synopsis "Extremely fast hash algorithm")
     (description