summary refs log tree commit diff
path: root/gnu/packages/dlang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/dlang.scm')
-rw-r--r--gnu/packages/dlang.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/dlang.scm b/gnu/packages/dlang.scm
index 15680cb079..729d6015ae 100644
--- a/gnu/packages/dlang.scm
+++ b/gnu/packages/dlang.scm
@@ -217,7 +217,8 @@ bootstrapping more recent compilers written in D.")
   (package
     (inherit ldc-bootstrap)
     (arguments
-     (substitute-keyword-arguments (package-arguments ldc-bootstrap)
+     (substitute-keyword-arguments
+       (strip-keyword-arguments '(#:tests?) (package-arguments ldc-bootstrap))
        ((#:make-flags _ #f)
         '(list "all"
                ;; Also build the test runner binaries.
@@ -226,7 +227,6 @@ bootstrapping more recent compilers written in D.")
         `(,@flags "-DBUILD_SHARED_LIBS=ON"
                   "-DLDC_LINK_MANUALLY=OFF"
                   "-DLDC_DYNAMIC_COMPILE=OFF"))
-       ((#:tests? _) #t)
        ((#:phases phases)
         `(modify-phases ,phases
            (add-after 'unpack 'fix-compiler-rt-library-discovery