summary refs log tree commit diff
path: root/gnu/packages/ed.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ed.scm')
-rw-r--r--gnu/packages/ed.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/ed.scm b/gnu/packages/ed.scm
index 953f739d31..3668aac19a 100644
--- a/gnu/packages/ed.scm
+++ b/gnu/packages/ed.scm
@@ -40,11 +40,12 @@
     (native-inputs `(("lzip" ,lzip)))
     (arguments
      '(#:configure-flags '("CC=gcc")
-       #:phases (alist-cons-before 'patch-source-shebangs 'patch-test-suite
-                                   (lambda _
-                                     (substitute* "testsuite/check.sh"
-                                       (("/bin/sh") (which "sh"))))
-                                   %standard-phases)))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'patch-source-shebangs 'patch-test-suite
+                     (lambda _
+                       (substitute* "testsuite/check.sh"
+                         (("/bin/sh") (which "sh"))))))))
     (home-page "http://www.gnu.org/software/ed/")
     (synopsis "Line-oriented text editor")
     (description