summary refs log tree commit diff
path: root/gnu/packages/education.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/education.scm')
-rw-r--r--gnu/packages/education.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/education.scm b/gnu/packages/education.scm
index c5055fc9d7..a8f1859dc5 100644
--- a/gnu/packages/education.scm
+++ b/gnu/packages/education.scm
@@ -678,6 +678,27 @@ hours.")
 language and very flexible regarding to new or unknown keyboard layouts.")
     (license license:gpl3+)))
 
+(define-public kqtquickcharts
+  (package
+    (name "kqtquickcharts")
+    (version "24.05.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://kde/stable/release-service/"
+                                  version "/src/kqtquickcharts-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0b0nqg77lzfw6accfsr4yg9fgq78skryd1qwkqf1zijhq4h65708"))))
+    (build-system qt-build-system)
+    (native-inputs (list extra-cmake-modules))
+    (inputs (list qtdeclarative-5))
+    (home-page "https://invent.kde.org/libraries/kqtquickcharts")
+    (synopsis "QtQuick plugin to render beautiful and interactive charts")
+    (description
+     "This package provides a QtQuick plugin to render beautiful and interactive
+charts.")
+    (license (list license:lgpl2.0+ license:gpl2+))))
+
 (define-public ktouch
   (package
     (name "ktouch")