summary refs log tree commit diff
path: root/gnu/packages/elf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/elf.scm')
-rw-r--r--gnu/packages/elf.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/elf.scm b/gnu/packages/elf.scm
index d4f75c9726..414d6a2856 100644
--- a/gnu/packages/elf.scm
+++ b/gnu/packages/elf.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018, 2020 Marius Bakke <mbakke@fastmail.com>
@@ -98,7 +98,14 @@
            (lambda _
              (substitute* "tests/Makefile.in"
                (("run-backtrace-native.sh") ""))
-             #t)))))
+             #t))
+         ,@(if (target-riscv64?)
+             `((add-after 'unpack 'disable-failing-riscv64-test
+                 (lambda _
+                   ;; dwfl_thread_getframes: No DWARF information found
+                   (substitute* "tests/Makefile.in"
+                     (("run-backtrace-dwarf.sh") "")))))
+             '()))))
 
     (native-inputs (list m4))
     (inputs (list zlib))
@@ -274,4 +281,7 @@ static analysis of the ELF binaries at hand.")
     (description
      "PatchELF allows the ELF \"interpreter\" and RPATH of an ELF binary to be
 changed.")
+    ;; This can probably be removed with the next release.
+    (properties
+     '((release-monitoring-url . "https://github.com/NixOS/patchelf/releases")))
     (license gpl3+)))