summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4344520430..3c3dad73f2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9166,6 +9166,15 @@ indentation guides in Emacs:
      `(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
        #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-ffip-project-search-call
+           (lambda _
+             ;; Since version 6.0.0 of find-file-in-project,
+             ;; ffip-project-search doesn't accept a third argument anymore
+             ;; (see: https://github.com/jorgenschaefer/elpy/issues/1889).
+             (substitute* "elpy.el"
+               (("\\((ffip-project-search nil nil) project-root\\)" _ signature)
+                (format #f "(let ((ffip-project-root project-root)) (~a))"
+                        signature)))))
          ;; The default environment of the RPC uses Virtualenv to install
          ;; Python dependencies from PyPI.  We don't want/need this in Guix.
          (add-before 'check 'do-not-use-virtualenv