summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm32
1 files changed, 31 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 4e83b3fcba..d734831f19 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30432,13 +30432,43 @@ original package.")
       (home-page "https://github.com/justbur/emacs-bind-map")
       (synopsis "Bind personal keymaps in multiple locations")
       (description
-"@code{emacs-bind-map} provides a macro bind-map which can be used to
+       "@code{emacs-bind-map} provides a macro bind-map which can be used to
 make a keymap available across different leader keys including ones
 tied to evil states.  It is essentially a generalization of the idea
 of a leader key as used in Vim or the @code{emacs-evil-leader} package,
 and allows for an arbitrary number of leader keys.")
       (license license:gpl3+))))
 
+(define-public emacs-spaceleader
+  (let ((commit "35368b03c094399c487cce93ab5b7ac725bd04f5")
+        (revision "0"))
+    (package
+      (name "emacs-spaceleader")
+      (version (git-version "0.0.3" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/mohkale/spaceleader")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1lg51y59z6igqjw3vgyjc5zw32j11xhzw8y0svlx3ry415b0lnls"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-dash
+             emacs-general
+             emacs-which-key
+             emacs-use-package
+             emacs-bind-map))
+      (home-page "https://github.com/mohkale/spaceleader")
+      (synopsis "Emacs leader key implementation from Spacemacs")
+      (description
+       "@code{emacs-spaceleader} replicates spacemacs' leader key features,
+without requiring all of spacemacs.  The @code{<Leader>} key, inspired by Vim,
+provides an easy way to bind keys under a configurable prefix key")
+      (license license:gpl3+))))
+
 (define-public emacs-promise
   (package
     (name "emacs-promise")