summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1750f00e87..9bb0470516 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26675,18 +26675,17 @@ other @code{helm-type-file} sources such as @code{helm-locate}.")
                         "emacs-telega-test-env.patch"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "INSTALL_PREFIX="
+                            (assoc-ref %outputs "out") "/bin"))
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'enter-subdirectory
            (lambda _ (chdir "server") #t))
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (substitute* "Makefile"
-                 (("CC=cc") ,(string-append "CC=" (cc-for-target)))
-                 (("^(INSTALL_PREFIX=).*$" _all prefix)
-                  (string-append prefix out "/bin\n")))
-
                (substitute* "run_tests.py"
                  (("^(TELEGA_SERVER = ).*$" _all prefix)
                   (string-append prefix