summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm44
1 files changed, 21 insertions, 23 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f3d136ebf1..12c9020f0e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8161,32 +8161,30 @@ src blocks.")
     (license license:gpl3+)))
 
 (define-public emacs-ol-notmuch
-  (let ((commit "1a53d6c707514784cabf33d865b577bf77f45913")
-        (revision "0"))
-    (package
-      (name "emacs-ol-notmuch")
-      (version (git-version "2.0.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://git.sr.ht/~tarsius/ol-notmuch")
-               (commit commit)))
-         (sha256
-          (base32
-           "16p7j51z8r047alwn2hkb6944f7ds29ckb97b4k8ia00vwch0d67"))
-         (file-name (git-file-name name version))))
-      (build-system emacs-build-system)
-      (propagated-inputs
-       (list emacs-compat emacs-notmuch emacs-org))
-      (home-page "https://git.sr.ht/~tarsius/ol-notmuch")
-      (synopsis "Links to notmuch messages for Emacs' Org mode")
-      (description
-       "This package implements links to Notmuch messages and searches for
+  (package
+    (name "emacs-ol-notmuch")
+    (version "2.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~tarsius/ol-notmuch")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32
+         "1rlpl3kb709q5brkjrrpirdnhvyh447q93li9lgfz67yya29rfqd"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     (list emacs-compat emacs-notmuch emacs-org))
+    (home-page "https://git.sr.ht/~tarsius/ol-notmuch")
+    (synopsis "Links to notmuch messages for Emacs' Org mode")
+    (description
+     "This package implements links to Notmuch messages and searches for
 Emacs' Org mode.  A search is a query to be performed by Notmuch; it is the
 equivalent to folders in other mail clients.  Similarly, mails are referred to
 by a query, so both a link can refer to several mails.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-debbugs
   (package