summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ee0aafc50f..6c9d493c62 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17847,13 +17847,13 @@ processes for Emacs")
              #t))
          (add-after 'install 'install-data
            (lambda* (#:key outputs #:allow-other-keys)
-             (let ((images (string-append (assoc-ref outputs "out")
-                                          "/share/" ,name "/images")))
+             (let ((out (assoc-ref outputs "out")))
                (with-directory-excursion "../.." ;treemacs root
-                 (copy-recursively "icons/default" images)
-                 (copy-recursively "src/scripts"
-                                   (string-append (assoc-ref outputs "out")
-                                                  "/share/" ,name "/scripts"))
+                 (copy-recursively "icons/default"
+                  (string-append out "/share/" ,name "/images"))
+                 (copy-recursively
+                  "src/scripts"
+                  (string-append out "/share/" ,name "/scripts"))
                  #t)))))))
     (home-page "https://github.com/Alexander-Miller/treemacs")
     (synopsis "Emacs tree style file explorer")