summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm37
1 files changed, 17 insertions, 20 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 23a0b92790..b0288eb6a7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25375,29 +25375,26 @@ mercury-mode provided by Emacs as a wrapper around prolog-mode.")
       (license license:gpl3+))))
 
 (define-public emacs-boxquote
-  ;; The following commit is 2.1 release with a switch to GPL3+ license.
-  (let ((commit "7e47e0e2853bc1215739b2e28f260e9eed93b2c5")
-        (revision "0"))
-    (package
-      (name "emacs-boxquote")
-      (version (git-version "2.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/davep/boxquote.el")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1aqhg24gajvllbqxb0zxrnx6sddas37k2ldfinqyszd856sjhsg3"))))
-      (build-system emacs-build-system)
-      (home-page "https://github.com/davep/boxquote.el")
-      (synopsis "Quote text with different kinds of boxes")
-      (description "@code{boxquote} provides a set of functions for using
+  (package
+    (name "emacs-boxquote")
+    (version "2.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/davep/boxquote.el")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0wwjawgylaaifdsszqxcfsyhfzgxbjkzqhzrnxnr9b16wghb7xf7"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/davep/boxquote.el")
+    (synopsis "Quote text with different kinds of boxes")
+    (description "@code{boxquote} provides a set of functions for using
 a text quoting style that partially boxes in the left hand side of an area of
 text, such a marking style might be used to show externally included text or
 example code.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-buffer-move
   (package