summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 825a355d63..9948b911d0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2941,3 +2941,22 @@ news items, openrc and runscripts.")
 in English as you type.  It primarily detects \"weasel words\" and abuse of
 passive voice.")
     (license license:gpl3+)))
+
+(define-public emacs-neotree
+  (package
+    (name "emacs-neotree")
+    (version "0.2.1")
+    (home-page "https://github.com/jaypei/emacs-neotree")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/jaypei/" name
+                    "/archive/v" version ".tar.gz"))
+              (sha256
+               (base32
+                "0cr37pdkwjgfijfws5bjskfh1rq9rfngxblcj6v5383vpmn83q7s"))
+              (file-name (string-append name "-" version))))
+    (build-system emacs-build-system)
+    (synopsis "Folder tree view for Emacs")
+    (description "This Emacs package provides a folder tree view.")
+    (license license:gpl3+)))