summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 480bbf7835..901afba29b 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1467,7 +1467,7 @@ handling communication with eBUS devices connected to a 2-wire bus system
 (define-public ucsim
   (package
     (name "ucsim")
-    (version "0.6-pre67")
+    (version "0.6-pre68")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -1475,7 +1475,7 @@ handling communication with eBUS devices connected to a 2-wire bus system
                     "devel/ucsim-" version ".tar.gz"))
               (sha256
                (base32
-                "0aahj9pbfjphjrm4hgs9pfmp6d5aikaq4yvxlrvhywjinnnf0qp1"))))
+                "1bfj21f5pcfcg1xqqynlcfr8mn6qj5705cgc2lfr2s3n97qsd9df"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--enable-avr-port"
@@ -1547,6 +1547,12 @@ and Zilog Z80 families, plus many of their variants.")
            (lambda _
              (substitute* (find-files "." "(\\.mk$|\\.in$)")
                (("/bin/sh") (which "sh")))
+             ;; --disable-ucsim disables sdcc-misc, patch it back in.
+             (substitute* "Makefile.in"
+               (("debugger/mcs51" line)
+                (string-append line  "\n"
+                               "TARGETS += sdcc-misc\n"
+                               "PKGS += $(SDCC_MISC)")))
              #t)))))
     (home-page "http://sdcc.sourceforge.net")
     (synopsis "C compiler suite for 8-bit microcontrollers")