summary refs log tree commit diff
path: root/gnu/packages/embedded.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/embedded.scm')
-rw-r--r--gnu/packages/embedded.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 901afba29b..8109ec24a1 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -1219,14 +1219,14 @@ SPI, I2C, JTAG.")
 (define-public fc-host-tools
   (package
     (name "fc-host-tools")
-    (version "14")
+    (version "15")
     (source (origin
               (method url-fetch)
               (uri (string-append "ftp://ftp.freecalypso.org/pub/GSM/"
                                   "FreeCalypso/fc-host-tools-r" version ".tar.bz2"))
               (sha256
                (base32
-                "09ccd76khfvlx4dwi9dhrzl5mm68402mlych0g7f9ncfr5jzyf26"))))
+                "17v3xc44mmlvp0irwm1p55zdgzd31ic3nsjxnv8y28a1i85103cv"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; No tests exist.
@@ -1237,17 +1237,13 @@ SPI, I2C, JTAG.")
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-installation-paths
            (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* '("Makefile"
-                            "rvinterf/etmsync/fsiomain.c"
-                            "rvinterf/etmsync/fsnew.c"
-                            "rvinterf/asyncshell/help.c"
-                            "rvinterf/libinterf/launchrvif.c"
-                            "loadtools/defpath.c"
-                            "loadtools/Makefile"
-                            "miscutil/c139explore"
-                            "miscutil/pirexplore"
-                            "ffstools/tiffs-wrappers/installpath.c"
-                            "uptools/atcmd/atinterf.c")
+             (substitute* (cons* "miscutil/c139explore"
+                                 "miscutil/pirexplore"
+                                 (find-files "." "^(.*\\.[ch]|Makefile)$"))
+               (("/opt/freecalypso/bin/fc-simtool")
+                "fc-simtool")
+               (("/opt/freecalypso/bin/fc-uicc-tool")
+                "fc-uicc-tool")
                (("/opt/freecalypso/loadtools")
                 (string-append (assoc-ref outputs "out") "/lib/freecalypso/loadtools"))
                (("\\$\\{INSTALL_PREFIX\\}/loadtools")
@@ -1301,6 +1297,9 @@ to flash storage.
 @item fc-iram: Allows running programs on the device without writing them
 to flash storage.
 @item fc-loadtool: Writes programs to the device's flash storage.
+@item fc-simint: Loads and runs simagent on the phone, then calls fc-simtool
+(see @url{https://www.freecalypso.org/hg/fc-sim-tools,fc-sim-tools
+repository}) on the host to connect to it.
 @item pirffs: Allows listing and extracting FFS content captured as a raw
 flash image from Pirelli phones.
 @item mokoffs: Allows listing and extracting FFS content captured as a raw