summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 13105ca8fa..77e8c76e17 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -135,6 +135,7 @@
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-science)
@@ -1288,7 +1289,7 @@ WiFi signal strength maps.  It visualizes them using a Voronoi diagram.")
 (define-public volk
   (package
     (name "volk")
-    (version "2.4.1")
+    (version "3.0.0")
     (source
      (origin
        (method git-fetch)
@@ -1298,19 +1299,26 @@ WiFi signal strength maps.  It visualizes them using a Voronoi diagram.")
              (recursive? #t)))          ; for cpu_features git submodule
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1mkqiw0i2fbbsk46zvk8yv5swl7ifhq6y1dlfphq8dsmkvxckqby"))))
+        (base32 "0a59lnjh6hx2bmyn04f8r0ymwss1ss1iih2jwrl9jblkxsw0i3lh"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'disable-check-lgpl-test
+           ;; Disable the failing check-lgpl test that is supposed to be run
+           ;; only by upstream developers to check the authors and licenses
+           ;; of contributions in the git history.
+           (lambda _
+             (substitute* "scripts/licensing/count_contrib.sh"
+               (("#!/bin/bash" all)
+                (string-append all "\nexit 0")))))
          (add-after 'install 'remove-static-libraries
            ;; Remove libcpu_features.a (and any others that might appear).
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (lib (string-append out "/lib")))
                (for-each delete-file (find-files lib "\\.a$"
-                                                 #:fail-on-error? #t))
-               #t)))
+                                                 #:fail-on-error? #t)))))
          (add-after 'install 'wrap-pythonpath
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -1326,8 +1334,7 @@ WiFi signal strength maps.  It visualizes them using a Voronoi diagram.")
                (wrap-program file
                  `("GUIX_PYTHONPATH" ":" prefix (,path))
                  `("PATH" ":" prefix
-                   (,(string-append python "/bin:")))))
-             #t)))))
+                   (,(string-append python "/bin:"))))))))))
     (inputs
      `(("boost" ,boost)
        ("python" ,python-wrapper)
@@ -1339,7 +1346,8 @@ WiFi signal strength maps.  It visualizes them using a Voronoi diagram.")
 with machine-specific optimizations for mathematical functions.  It also
 provides a machine-independent interface to select the best such procedures to
 use on a given system.")
-    (license license:gpl3+)))
+    (license (list license:asl2.0 ; cpu_features
+                   license:lgpl3+))))
 
 (define-public libredwg
   (package
@@ -2456,7 +2464,7 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
                             (substitute* "pyvisa/shell.py"
                               (("from .thirdparty import prettytable")
                                "import prettytable")))))))
-    (native-inputs (list python-pytest-7.1))
+    (native-inputs (list python-pytest))
     (propagated-inputs (list python-dataclasses python-prettytable
                              python-typing-extensions))
     (home-page "https://pyvisa.readthedocs.io/en/latest/")
@@ -2493,7 +2501,7 @@ measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
                          python-flake8
                          python-nbval
                          python-networkx
-                         python-pytest-7.1
+                         python-pytest
                          python-pytest-cov
                          python-pyvisa))
     (home-page "https://scikit-rf.org/")