summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ea5dd885d1..ad7ae18781 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2019 Tim Stahel <swedneck@swedneck.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1911,3 +1912,24 @@ editors.")
                    license:cc0 ; libs/optional, libs/sexpresso
                    license:bsd-2 ; libs/optional/tests/catch.hpp
                    license:lgpl2.1+)))) ; libs/quazip
+
+(define-public gpx
+  (package
+    (name "gpx")
+    (version "2.5.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/markwal/GPX.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "1yab269x8qyf7rd04vaxyqyjv4pzz9lp4sc4dwh927k23avr3rw5"))))
+    (build-system gnu-build-system)
+    (home-page "https://github.com/markwal/GPX")
+    (synopsis "Converting gcode to x3g files for 3D printing")
+    (description
+     "GPX is a post processing utility for converting gcode output from 3D
+slicing software to x3g files for standalone 3D printing on common 3D
+printers.")
+    (license license:gpl2+)))