summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 8578789872..3bb49ff549 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -717,11 +717,11 @@ electrical diagrams), gerbview (viewing Gerber files) and others.")
          (modify-phases %standard-phases
            (add-after 'install 'install-footprints ; from footprints tarball
              (lambda* (#:key inputs outputs #:allow-other-keys)
-               (zero? (system* "tar" "xvf"
-                               (assoc-ref inputs "kicad-footprints")
-                               "-C" (string-append (assoc-ref outputs "out")
-                                                   "/share/kicad/modules")
-                               "--strip-components=1"))))
+               (invoke "tar" "xvf"
+                       (assoc-ref inputs "kicad-footprints")
+                       "-C" (string-append (assoc-ref outputs "out")
+                                           "/share/kicad/modules")
+                       "--strip-components=1")))
            ;; We change the default global footprint file, which is generated if
            ;; it doesn't exist in user's home directory, from the one using the
            ;; github plugin, to the one using the KISYSMOD environment path.