summary refs log tree commit diff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm39
1 files changed, 26 insertions, 13 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 790be1a59e..11fcf0b7b0 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
 ;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 ng0 <ng0@n0.is>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
@@ -65,18 +65,17 @@
 (define-public efl
   (package
     (name "efl")
-    (version "1.21.1")
+    (version "1.22.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
                     "https://download.enlightenment.org/rel/libs/efl/efl-"
                     version ".tar.xz"))
-              (patches (search-patches "efl-mesa-compat.patch"))
               (sha256
                (base32
-                "0a5907h896pvpix7a6idc2fspzy6d78xrzf84k8y9fyvnd14nxs4"))))
-    (outputs '("out"       ; 49 MB
-               "include")) ; 17 MB
+                "1l0wdgzxqm2y919277b1p9d37xzg808zwxxaw0nn44arh8gqk68n"))))
+    (outputs '("out"       ; 53 MB
+               "include")) ; 21 MB
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -91,6 +90,7 @@
        ("libjpeg" ,libjpeg)
        ("libraw" ,libraw)
        ("librsvg" ,librsvg)
+       ("libsndfile" ,libsndfile)
        ("libspectre" ,libspectre)
        ("libtiff" ,libtiff)
        ("libwebp" ,libwebp)
@@ -113,6 +113,7 @@
        ("openjpeg" ,openjpeg-1)
        ("poppler" ,poppler)
        ("printproto" ,printproto)
+       ("pulseaudio" ,pulseaudio)
        ("wayland-protocols" ,wayland-protocols)
        ("xinput" ,xinput)
        ("xpr" ,xpr)
@@ -131,11 +132,9 @@
        ("luajit" ,luajit) ; elua.pc, evas.pc, evas-cxx.pc
        ("libinput" ,libinput-minimal) ; elput.pc
        ("libpng" ,libpng) ; evas.pc, evas-cxx.pc
-       ("libsndfile" ,libsndfile) ; ecore-audio.pc, ecore-audio-cxx.pc
        ("libxkbcommon" ,libxkbcommon) ; ecore-wl2.pc, elementary.pc, elput.pc
        ("mesa" ,mesa) ; ecore-drm2.pc
        ("openssl" ,openssl) ; ecore-con.pc, eet.pc, eet-cxx.pc, emile.pc
-       ("pulseaudio" ,pulseaudio) ; ecore-audio.pc, ecore-audio-cxx.pc
        ("util-linux" ,util-linux) ; mount: eeze.pc
        ("wayland" ,wayland) ; ecore-wl2.pc, elementary.pc
        ("zlib" ,zlib))) ; eet.pc, eet-cxx.pc, emile.pc
@@ -204,7 +203,10 @@ removable devices or support for multimedia.")
                   #t))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Dtests=true")
+     `(#:configure-flags (list "-Dtests=true"
+                               (string-append "-Dedje-cc="
+                                              (assoc-ref %build-inputs "efl")
+                                              "/bin/edje_cc"))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'set-home-directory
@@ -287,6 +289,7 @@ Libraries with some extra bells and whistles.")
        (modify-phases %standard-phases
          (add-before 'configure 'set-system-actions
            (lambda* (#:key inputs #:allow-other-keys)
+            (setenv "HOME" "/tmp")
              (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
                    (setxkbmap (assoc-ref inputs "setxkbmap"))
                    (utils     (assoc-ref inputs "util-linux"))
@@ -347,15 +350,25 @@ embedded systems.")
 (define-public python-efl
   (package
     (name "python-efl")
-    (version "1.21.0")
+    (version "1.22.0")
     (source
       (origin
         (method url-fetch)
-        (uri (string-append "http://download.enlightenment.org/rel/bindings/"
+        (uri (string-append "https://download.enlightenment.org/rel/bindings/"
                             "python/python-efl-" version ".tar.xz"))
         (sha256
          (base32
-          "08x2cv8hnf004c3711250wrax21ffj5y8951pvk77h98als4pq47"))))
+          "1qhy63c3fs2bxkx2np5z14hyxbr12ii030crsjnhpbyw3mic0s63"))
+        (modules '((guix build utils)))
+        ;; Remove files generated by Cython
+        (snippet
+          '(begin
+             (copy-file "efl/dbus_mainloop/e_dbus.c" "efl/dbus_mainloop/e_dbus.q")
+             (for-each delete-file (find-files "efl" ".*\\.c$"))
+             (delete-file "efl/eo/efl.eo_api.h")
+             (copy-file "efl/dbus_mainloop/e_dbus.q" "efl/dbus_mainloop/e_dbus.c")
+             (delete-file "efl/dbus_mainloop/e_dbus.q")
+             #t))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -471,7 +484,7 @@ and in creating applications based on the Enlightenment Foundation Library suite
                                   "apps/ephoto/ephoto-" version ".tar.xz")))
         (sha256
          (base32
-          "04kli43sfsy6s660g13pjc0kjmgdcmq8m4qh02vvpcwv60mf9mgz"))))
+          "1q7v9abjp9jrs08xc7pqaac64yzax24dk1snjb9rciarzzh3mlzy"))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases