summary refs log tree commit diff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm29
1 files changed, 5 insertions, 24 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index d52d5c3983..e1ffe76f29 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Nikita <nikita@n0.is>
 ;;; Copyright © 2021 Oskar Köök <oskar@maatriks.ee>
+;;; Copyright © 2021 Cees de Groot <cg@evrl.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -30,7 +31,6 @@
   #:use-module (guix packages)
   #:use-module (guix utils)
   #:use-module (gnu packages)
-  #:use-module (gnu packages autotools)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages ncurses)
@@ -41,7 +41,7 @@
 (define-public erlang
   (package
     (name "erlang")
-    (version "23.2.1")
+    (version "24.0.2")
     (source (origin
               (method git-fetch)
               ;; The tarball from http://erlang.org/download contains many
@@ -53,13 +53,11 @@
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1p3lw4bcm2dph3pf1h4i0d9pzrcfr83r0iadqanxkwbmm1bl11pm"))
+                "06plnhi1489wqsag5wgm16hb1xd1a8nbnb9gw7635d3fidxyb0wp"))
               (patches (search-patches "erlang-man-path.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("perl" ,perl)
-       ("autoconf" ,autoconf)
-       ("automake" ,automake)
 
        ;; Erlang's documentation is distributed in a separate tarball.
        ("erlang-manpages"
@@ -69,7 +67,7 @@
                                (version-major+minor version) ".tar.gz"))
            (sha256
             (base32
-             "0rq0rw68f02vckgdiwmvx8bvyv00l81s27cq59i3h79j9prfal2n"))))))
+             "1c9ccp93pmm54mmvpiyrmj8v00pq11a60c4xv220k97i965zkwsg"))))))
     (inputs
      `(("ncurses" ,ncurses)
        ("openssl" ,openssl)
@@ -177,18 +175,6 @@
            (lambda _
              (setenv "ERL_TOP" (getcwd))
              #t))
-         (add-after 'patch-source-env 'autoconf
-           (lambda _
-             (invoke "./otp_build" "autoconf")
-             #t))
-         (add-after 'autoconf 'patch-configure-script-shell
-           (lambda _
-             (substitute* "configure"
-               (("cmd_str=\"./configure")
-                (string-append "cmd_str=\""
-                               (which "sh")
-                               " ./configure")))
-             #t))
          (add-after 'install 'patch-erl
            ;; This only works after install.
            (lambda* (#:key outputs #:allow-other-keys)
@@ -202,13 +188,8 @@
                     (manpages (assoc-ref inputs "erlang-manpages"))
                     (share (string-append out "/share/")))
                (mkdir-p share)
-               (mkdir-p (string-append share "/misc/erlang"))
                (with-directory-excursion share
-                 (invoke "tar" "xvf" manpages)
-                 (rename-file "COPYRIGHT"
-                              (string-append share "/misc/erlang/COPYRIGHT"))
-                 ;; Delete superfluous file.
-                 (delete-file "PR.template"))
+                 (invoke "tar" "xvf" manpages))
                #t))))))
     (home-page "https://www.erlang.org/")
     (synopsis "The Erlang programming language")