summary refs log tree commit diff
path: root/gnu/packages/file-systems.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file-systems.scm')
-rw-r--r--gnu/packages/file-systems.scm30
1 files changed, 17 insertions, 13 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index 216e4cfcda..a792bd8700 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -3,7 +3,7 @@
 ;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
 ;;; Copyright © 2017, 2018, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019-2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021 raid5atemyhomework <raid5atemyhomework@protonmail.com>
@@ -428,7 +428,9 @@ from a mounted file system.")
                      "INITRAMFS_DIR=$(PREFIX)/share/initramfs-tools"
                      (string-append "CC=" #$(cc-for-target))
                      (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
-                     "PYTEST=pytest")
+                     (string-append "PYTEST_CMD="
+                                    #$(this-package-native-input "python-pytest")
+                                    "/bin/pytest"))
              #:phases
              #~(modify-phases %standard-phases
                  (delete 'configure)    ; no configure script
@@ -444,16 +446,18 @@ from a mounted file system.")
                            ,(list (string-append #$output            "/sbin")
                                   (string-append #$coreutils-minimal "/bin")
                                   (string-append #$gawk              "/bin")
-                                  (string-append #$util-linux        "/bin"))))))))
-             #:tests? #f))                  ; XXX 6 valgrind tests fail
+                                  (string-append #$util-linux        "/bin"))))))))))
       (native-inputs
-       (list pkg-config
-             ;; For tests.
-             python-pytest
-             valgrind
-             ;; For generating documentation with rst2man.
-             python
-             python-docutils))
+       (append
+         (list pkg-config
+               ;; For tests.
+               python-pytest)
+         (if (member (%current-system) (package-supported-systems valgrind))
+           (list valgrind)
+           '())
+         ;; For generating documentation with rst2man.
+         (list python
+               python-docutils)))
       (inputs
        (list eudev
              keyutils
@@ -1146,7 +1150,7 @@ with the included @command{xfstests-check} helper.")
 (define-public zfs
   (package
     (name "zfs")
-    (version "2.1.4")
+    (version "2.1.5")
     (outputs '("out" "module" "src"))
     (source
       (origin
@@ -1155,7 +1159,7 @@ with the included @command{xfstests-check} helper.")
                               "/download/zfs-" version
                               "/zfs-" version ".tar.gz"))
           (sha256
-           (base32 "1xmcy4f0damf1pkb1sy1339ir1jkky0dwzd8vhwgc1pqjgac0liv"))))
+           (base32 "0371j5k28cymqngfl76dfxzggvdf8n0ssij37350gzs4bhg084qr"))))
     (build-system linux-module-build-system)
     (arguments
      (list