summary refs log tree commit diff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 24ed37a9d2..9ba51d1b74 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -43,7 +43,9 @@
 
    ;; When cross-compiling, this package depends upon a native install of
    ;; itself.
-   (self-native-input? #t)
+   (native-inputs (if (%current-target-system)
+                      `(("self" ,this-package))
+                      '()))
 
    (synopsis "File type guesser")
    (description