summary refs log tree commit diff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index d04357023d..9ba51d1b74 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -31,11 +31,11 @@
   (package
     (name "file")
     (version "5.33")
-    (replacement file/fixed)
     (source (origin
               (method url-fetch)
               (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
                                   version ".tar.gz"))
+              (patches (search-patches "file-CVE-2018-10360.patch"))
               (sha256
                (base32
                 "1iipnwjkag7q04zjkaqic41r9nlw0ml6mhqian6qkkbisb1whlhw"))))
@@ -55,10 +55,3 @@ extensions to tell you the type of a file, but looks at the actual contents
 of the file.  This package provides the libmagic library.")
    (license bsd-2)
    (home-page "https://www.darwinsys.com/file/")))
-
-(define file/fixed
-  (package
-    (inherit file)
-    (source
-      (origin (inherit (package-source file))
-              (patches (search-patches "file-CVE-2018-10360.patch"))))))